Last Comment Bug 697413 - Usage of progress bar for visualizing imap quota is irritating - details window only
: Usage of progress bar for visualizing imap quota is irritating - details wind...
Status: RESOLVED FIXED
: ux-consistency
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: 7 Branch
: x86 Mac OS X
: -- trivial (vote)
: Thunderbird 11.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-26 06:32 PDT by Patrick Julian
Modified: 2011-11-17 03:16 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
n/a
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
This is the bar that I was describing (80.43 KB, image/png)
2011-10-26 08:04 PDT, Patrick Julian
no flags Details
details window still with the old bar style (25.50 KB, image/png)
2011-10-26 08:25 PDT, Patrick Julian
no flags Details
Copy the QuotaPanel style to the folder properties (2.21 KB, patch)
2011-10-29 01:15 PDT, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review

Description Patrick Julian 2011-10-26 06:32:03 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Tested under Mac OS X (10.6.8) with v7.0.1
Open an IMAP email account with given quota of 500MB


Actual results:

in the status bar at the bottom of the main window, a progress bar indicates the amount of the quota that is consumed in the account already. The amount percent value is correct, but the progress bar's permanent animation is irritating  


Expected results:

since the described issue is not actually a running process but a rather static value indicator, this should imho not use a progress bar but another more appropriate UI element
Comment 1 David :Bienvenu 2011-10-26 07:41:42 PDT
by animation, do you mean display? Do you actually see it changing?
Comment 2 Patrick Julian 2011-10-26 07:48:13 PDT
I mean that OS X default behaviour: The blue bar consists of blue vertical stripes that slowly move right to left. The value remains the same. It only makes an impression to the user as if something were being computed or such.

I guess it becomes more apparent what I mean when you click the bar. In the modal window you will see the bar in bigger resolution.
Comment 3 David :Bienvenu 2011-10-26 07:49:59 PDT
The quota bar is either green, yellow, or red, and doesn't animate, afaik. It sounds like you're talking about the progress bar, which is blue, and animates.
Comment 4 Ben Bucksch (:BenB) 2011-10-26 07:55:43 PDT
I don't have a mac, but I think we explicitly disabled the native progress bar look in the themes.

Are you using a different theme (skin)?
Comment 5 Ben Bucksch (:BenB) 2011-10-26 07:56:20 PDT
That change was in bug 385175, FWIW.
Comment 6 Ben Bucksch (:BenB) 2011-10-26 07:57:11 PDT
Patrick, did this work for you in previous releases of TB? If so, that would point to a regression by the above mentioned bug.
Comment 7 Ben Bucksch (:BenB) 2011-10-26 07:58:38 PDT
bienvenu, the commit http://hg.mozilla.org/comm-central/rev/6b7bd9c1ac6c , would it appear in TB 7.0.1 or not?

Patrick, could you please test trunk builds of Thunderbird ("Early Bird")?
Comment 8 Patrick Julian 2011-10-26 08:04:23 PDT
Created attachment 569680 [details]
This is the bar that I was describing
Comment 9 David :Bienvenu 2011-10-26 08:06:12 PDT
(In reply to Ben Bucksch (:BenB) from comment #7)
> bienvenu, the commit http://hg.mozilla.org/comm-central/rev/6b7bd9c1ac6c ,
> would it appear in TB 7.0.1 or not?
No, loooks like the TFV is TB 9.

Sorry, Patrick, I didn't realize that this stuff had changed.
Comment 10 Ben Bucksch (:BenB) 2011-10-26 08:07:29 PDT
Good. My guess is that this is already fixed in trunk.
Comment 11 Patrick Julian 2011-10-26 08:08:15 PDT
Hi guys, no I am currently running the default theme; currently there are not even any other themes installed. In previous releases, I did not even notice the presence of any such bar. I can test an early bird version if further clarification on this is still required.
Comment 12 Ludovic Hirlimann [:Usul] 2011-10-26 08:13:06 PDT
The one I'm seeing is different on Early bird - earlybird is available at https://www.mozilla.org/en-US/thunderbird/channel/
Comment 13 Ben Bucksch (:BenB) 2011-10-26 08:15:45 PDT
> I can test an early bird version if further clarification on this is still required.

Yes, it is.
Comment 14 Patrick Julian 2011-10-26 08:24:20 PDT
Sweet icon :)

OK it renders differently (better) in the status bar in 9.0a2.

However, the details window still renders it the old way. I'll file another attachment.
Comment 15 Patrick Julian 2011-10-26 08:25:07 PDT
Created attachment 569687 [details]
details window still with the old bar style
Comment 16 Ben Bucksch (:BenB) 2011-10-26 08:31:06 PDT
Thanks for confirming that the original bug is FIXED.

Details window: OK, that's a point.
I think this is a minor bug now, though.

New Objective: Apply fix for bug 385175 to quota in folder details window.
Comment 17 Patrick Julian 2011-10-26 08:37:22 PDT
ok - agreed - thank you guys!
Comment 18 Richard Marti (:Paenglab) 2011-10-29 01:15:59 PDT
Created attachment 570465 [details] [diff] [review]
Copy the QuotaPanel style to the folder properties

The quota in the folder properties has with this patch the same appearance as the QuotPanel in the statusbar. I only gave the normal color because I haven't found code which gives a warning or critical state.

I had to add a stylesheet definition on folderProps.xul under mailnews. I checked with Seamonkey and saw no problem with this stylesheet definition under it.
Comment 19 Blake Winton (:bwinton) (:☕️) 2011-11-14 12:29:17 PST
Comment on attachment 570465 [details] [diff] [review]
Copy the QuotaPanel style to the folder properties

Review of attachment 570465 [details] [diff] [review]:
-----------------------------------------------------------------

Aside from the question below, I think this looks good (at least on Windows).  r=me, and ui-r=me.

::: mail/themes/gnomestripe/mail/preferences/preferences.css
@@ -94,0 +94,11 @@
> > +
> > +/* Quota meter in Folder Properties */
> > +
> > +#quotaPercentageBar {
NaN more ...

So, why not have the same high/medium/low colours in the folder properties, too?
Comment 20 Richard Marti (:Paenglab) 2011-11-14 13:08:16 PST
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #19)
> So, why not have the same high/medium/low colours in the folder properties,
> too?

As I wrote in comment 18: I only gave the normal color because I haven't found code which gives a warning or critical state.

Do you see somewhere code which detects the warning or critical levels? I have only at GMail an IMAP account with quota and with only 2% filled I'm unable to check this.
Comment 21 David :Bienvenu 2011-11-14 13:13:52 PST
BenB probably remembers better than I do, but I believe it's yellow over a certain level and red after that. There are thresholds specified in prefs - look at mail.quota.* in the config editor.

Also, use mxr to look for UpdateStatusQuota
Comment 22 Richard Marti (:Paenglab) 2011-11-14 13:47:37 PST
(In reply to David :Bienvenu from comment #21)
> BenB probably remembers better than I do, but I believe it's yellow over a
> certain level and red after that.

I think you have seen this in the status bar where this styling is applied. The progress bar in the folder properties had no special styling, so I don't think it had other colors.

Better we're waiting for BenB for an answer.
Comment 23 David :Bienvenu 2011-11-14 14:03:43 PST
I believe you're right - it's possible that we'd need to do more work to expose this state to the theme for the folder properties dialog.
Comment 24 Ben Bucksch (:BenB) 2011-11-14 14:42:54 PST
I don't think there's code to mark it "warning"/"critical" for the folderProperties, only the main window status bar. I personally don't think it's important either, because the bar is much bigger and pretty obvious as-is, while the small status bar needs additional hints.
Comment 25 Richard Marti (:Paenglab) 2011-11-14 23:02:36 PST
I'm setting checkin-needed because I think bwintons question is answered.
Comment 26 Mark Banner (:standard8) 2011-11-17 03:16:30 PST
Checked in: http://hg.mozilla.org/comm-central/rev/806680a1df40

Note You need to log in before you can comment on or make changes to this bug.