add a JS-only way to get a non-WANT_ALL_TRACES cycle collector dump

RESOLVED DUPLICATE of bug 688225

Status

()

RESOLVED DUPLICATE of bug 688225
7 years ago
7 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
WANT_ALL_TRACES cycle collector dumps are nice because they have more information about the heap, but they don't provide an accurate picture of what the cycle collector does, which might be important when remotely diagnosing cycle collector performance problems.

One way to implement this would be to have a boolean property on a listener that says whether it wants WANT_ALL_TRACES or not, then have the constructor for the default dumping listener have an optional argument that sets the property.
(Reporter)

Comment 1

7 years ago
I think I'm just going to add an additional pref in bug 668225 to control whether dumps are WANT_ALL_TRACES or not.  My original idea was to expose it to JS so we could ask people to use a different magic invocation of the CC dump, but generally I'd like to get away from people using that and towards using a config, so we get avoid Heisenberg problems.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668225

Comment 2

7 years ago
Wrong dup bug num?
(Reporter)

Comment 3

7 years ago
Ah, thanks.  Man, I am not doing well with bug numbers today.
Duplicate of bug: 688225
You need to log in before you can comment on or make changes to this bug.