Closed Bug 697469 Opened 11 years ago Closed 11 years ago

crash mozalloc_abort - Fennec process dies on tap of AwesomeBar

Categories

(Firefox for Android Graveyard :: General, defect, P1)

ARM
Android
defect

Tracking

(firefox11 verified, firefox12 verified, firefox13 verified, fennec11+)

VERIFIED FIXED
Tracking Status
firefox11 --- verified
firefox12 --- verified
firefox13 --- verified
fennec 11+ ---

People

(Reporter: kbrosnan, Assigned: bnicholson)

References

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-54b42300-a70e-403c-95d0-2efb02111026 .
============================================================= 

I get this crash when clicking on the address bar in Native Fennec on the Droid Pro Android 2.2.1.
Duplicate of this bug: 697481
I/ActivityManager( 1940): Starting: Intent { flg=0x40010000 cmp=org.mozilla.fennec/org.mozilla.gecko.AwesomeBar (has extras) } from pid 8662
I/ActivityManager( 1940): Displayed org.mozilla.fennec/org.mozilla.gecko.AwesomeBar: +307ms
I/ActivityManager( 1940): Process org.mozilla.fennec (pid 8662) has died.

STR:
1. Launch Fennec
2. Tap AwesomeBar

--
20111026100509
http://hg.mozilla.org/projects/birch/rev/0668a17050a3
Samsung Galaxy S
Summary: crash mozalloc_abort → crash mozalloc_abort - Fennec process dies on tap of AwesomeBar
Attached patch remove isEmpty()Splinter Review
isEmpty() was introduced in API level 9; this patch replaces it
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #569775 - Flags: review?(doug.turner)
Attachment #569775 - Flags: review?(doug.turner) → review+
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [native-crash]
tracking-fennec: --- → 11+
Verified fixed on:

Firefox 13.0a1 (2012-02-20)
20120220031231
http://hg.mozilla.org/mozilla-central/rev/561771f01881

Firefox 12.0a2 (2012-02-20)
20120220042008
http://hg.mozilla.org/releases/mozilla-aurora/rev/dfb7c3567c49

Firefox 11.0 (2012-02-19)
20120219151859
http://hg.mozilla.org/releases/mozilla-beta/rev/6df75f4d5ccc

--
Device: Motorola Droid PRO
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.