Last Comment Bug 697475 - deCOMtaminate nsSVGPatternFrame::GetPatternFirstChild
: deCOMtaminate nsSVGPatternFrame::GetPatternFirstChild
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Daniel Holbert [:dholbert]
:
: Jet Villegas (:jet)
Mentors:
Depends on: 336653
Blocks: deCOM
  Show dependency treegraph
 
Reported: 2011-10-26 10:13 PDT by Daniel Holbert [:dholbert]
Modified: 2011-10-28 04:30 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.43 KB, patch)
2011-10-26 11:07 PDT, Daniel Holbert [:dholbert]
longsonr: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-10-26 10:13:17 PDT
This MXR search...
http://mxr.mozilla.org/mozilla-central/search?string=PatternFirstChild
...shows that GetPatternFirstChild() is only mentioned inside of nsSVGPatternFrame.[h,cpp]

This currently has NS_IMETHOD / NS_IMETHODIMP annotations, but these aren't necessary, because the method isn't declared in an IDL file.

This method can just return nsresult.

BTW, hg/cvs archeology shows that the line of code with this method's declaration hasn't changed since the original revision of the file, from bug 336653 ("Remove nsISVGPattern").  So, presumably this is just left over from when we had an XPCOM nsISVGPattern interface.

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/svg/base/src/nsSVGPatternFrame.h#135
Comment 1 Daniel Holbert [:dholbert] 2011-10-26 10:26:51 PDT
Actually, this method can just directly return a nsIFrame*.
Comment 2 Daniel Holbert [:dholbert] 2011-10-26 11:07:50 PDT
Created attachment 569730 [details] [diff] [review]
fix
Comment 3 Daniel Holbert [:dholbert] 2011-10-27 16:01:18 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b317557f9b78
Comment 4 Ed Morley [:emorley] 2011-10-28 04:30:04 PDT
https://hg.mozilla.org/mozilla-central/rev/b317557f9b78

Note You need to log in before you can comment on or make changes to this bug.