Closed Bug 69758 Opened 22 years ago Closed 7 years ago

block cookies by site matching regexp

Categories

(Core :: Networking: Cookies, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: basic, Unassigned)

References

(Depends on 1 open bug)

Details

The ability to to use regular expression to match sites in the cookie and image
manager feature.
.
Assignee: morse → nobody
status to NEW
reporter, I think, if you want this feature implemented, you'll have to come up
with a patch yourself
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 72072 has been marked as a duplicate of this bug. ***
adding [RFE]
Summary: filter cookies/images with site matching regular expression → [RFE] filter cookies/images with site matching regular expression
*** Bug 126635 has been marked as a duplicate of this bug. ***
*** Bug 146980 has been marked as a duplicate of this bug. ***
*** Bug 154146 has been marked as a duplicate of this bug. ***
Pattern-matching based image blocking is in bug 78104 (and there is already a patch)
*** Bug 104043 has been marked as a duplicate of this bug. ***
Depends on: 78104
Summary: [RFE] filter cookies/images with site matching regular expression → filter cookies/images with site matching regular expression
*** Bug 221537 has been marked as a duplicate of this bug. ***
Firebird. AdBlock extension. I'm happy. :-)
*** Bug 299702 has been marked as a duplicate of this bug. ***
no regexps, but you can use typeaheadfind in firefox now. i think that's as far as we're going to go wrt searching -> wfm
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
I don't understand how typeaheadfind can be used in Cookie Manager and Image Manager to create static filters that will work for related domains.  The idea is to create a single manager entry that will work for both m2.doubleclick.com and m3.doubleclick.com with a single m?.doubleclick.com entry.  
sorry, misinterpreted the summary and comments here. updating summary and reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: filter cookies/images with site matching regular expression → block cookies by site matching regexp
Filter on "Nobody_NScomTLD_20080620"
Status: REOPENED → NEW
QA Contact: tever → networking.cookies
Even just a simple wild card would be a step in the right direction.

i.e. 

ad.*.* - to allow filtering of any sub-domain named ad.

*I know this bug refers explicitly to regex, however, 

1) This was marked as a duplicate of [ https://bugzilla.mozilla.org/show_bug.cgi?id=299702 ], which only refers to wildcards.
2) Only coders use regex, most of whom in my experience typically find them a pain.
this is the domain of addons
Status: NEW → RESOLVED
Closed: 15 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.