Bypass unresponsive script warning

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: aquilax, Unassigned)

Tracking

6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 569831 [details]
UnresponsiveScript.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I'm plagued with this warning, I have also changed the max_script_run_time to 100 but it continues to popup. Please add an option in the about:config to bypass this warning.


Actual results:

When it happens? Most of the times when I close firefox and then the laptop, but firefox is still running in background and get hibernate from the laptop closing, when I wake up the laptop I see the warning from the unresponsive script. It happens also if I leave firefox open and go away without closing the laptop, the laptop doesn't go in hibernate mode but it turn off the lcd screen and reduces the used resources to save energy, when I come back most of the times the "unresponsive script" popup is there.
It happens also that more than one "unresponsive script" popped up, I have already dismissed five or six of them!


Expected results:

I would like to have the behavior of before without this, for me, useless and annoying popup.

Comment 1

7 years ago
Have you tried setting dom.max_script_run_time and dom.max_chrome_script_run_time to 0 or negative values?
(Reporter)

Comment 2

7 years ago
I set the values to -1 and now since a few days I don't get it any more.
Thanks

Comment 3

7 years ago
OK, but understand that you have disabled this safety warning also for sites that use long running scripts and will hog your CPU indefinitely without any way for you to stop it. But you probably haven't encountered such so good for you :)

It seems we can close this. Reopen if you find out you still get the warning with the value set to -1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

7 years ago
Thanks for the interest but I'm working it the IT and if some script gets unresponsive I will kill FF process ;)
You need to log in before you can comment on or make changes to this bug.