Fix stlport linking for ARMv6 Android builds

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-bs)

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
dbaron told me he hit this issue while trying to do ARMv6 Android builds. His workaround patch is here:
http://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/e1e1674dd1d4/no-armv7a

I have a patch that should be okay to commit, it involves a fair amount of code shuffling in configure.
(Assignee)

Updated

6 years ago
Blocks: 697205
(Assignee)

Comment 1

6 years ago
Created attachment 570009 [details] [diff] [review]
shuffle around some blocks in configure so we can choose the right STLport flavor for ARMv6 Android builds

This seems to build for me, but I don't have an actual ARMv6 device to test on. (This phone dougt gave me is actual ARMv5TE.)
(Assignee)

Updated

6 years ago
Attachment #570009 - Flags: review?(mh+mozilla)
Attachment #570009 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 2

6 years ago
http://hg.mozilla.org/projects/build-system/rev/5a26ca9a23f9
Assignee: ted.mielczarek → nobody
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Whiteboard: fixed-in-bs
Assignee: nobody → ted.mielczarek
(Assignee)

Updated

6 years ago
Duplicate of this bug: 661463
Blocks: 617115
(Assignee)

Comment 4

6 years ago
http://hg.mozilla.org/mozilla-central/rev/5a26ca9a23f9
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.