Last Comment Bug 697709 - Fix stlport linking for ARMv6 Android builds
: Fix stlport linking for ARMv6 Android builds
Status: RESOLVED FIXED
fixed-in-bs
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
:
Mentors:
: 661463 (view as bug list)
Depends on:
Blocks: 617115 697205
  Show dependency treegraph
 
Reported: 2011-10-27 07:11 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-11-11 07:33 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
shuffle around some blocks in configure so we can choose the right STLport flavor for ARMv6 Android builds (35.25 KB, patch)
2011-10-27 09:44 PDT, Ted Mielczarek [:ted.mielczarek]
mh+mozilla: review+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2011-10-27 07:11:19 PDT
dbaron told me he hit this issue while trying to do ARMv6 Android builds. His workaround patch is here:
http://hg.mozilla.org/users/dbaron_mozilla.com/patches/raw-file/e1e1674dd1d4/no-armv7a

I have a patch that should be okay to commit, it involves a fair amount of code shuffling in configure.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-10-27 09:44:51 PDT
Created attachment 570009 [details] [diff] [review]
shuffle around some blocks in configure so we can choose the right STLport flavor for ARMv6 Android builds

This seems to build for me, but I don't have an actual ARMv6 device to test on. (This phone dougt gave me is actual ARMv5TE.)
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-10-28 07:22:13 PDT
http://hg.mozilla.org/projects/build-system/rev/5a26ca9a23f9
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-11-02 11:15:19 PDT
*** Bug 661463 has been marked as a duplicate of this bug. ***
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-11-11 07:33:19 PST
http://hg.mozilla.org/mozilla-central/rev/5a26ca9a23f9

Note You need to log in before you can comment on or make changes to this bug.