"Run Junk Mail Controls on Folder" quits early with error gMessengerBundle is not defined chrome://messenger/content/junkCommands.js Line: 276

RESOLVED FIXED in Thunderbird 11.0

Status

MailNews Core
Filters
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Nathan Mahon, Assigned: aceman)

Tracking

({regression})

Thunderbird 11.0
x86
Windows 7
regression
Bug Flags:
in-testsuite ?

Thunderbird Tracking Flags

(thunderbird10 fixed)

Details

(Whiteboard: [gs][gssolved], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Checking a large (1000 message) IMAP folder for junk mail.
Selected folder, selected Tools->Run Junk Mail Controls on Folder



Actual results:

the first approximately 20 messages were marked junk (correctly) in approximately one second.  It then stopped checking and the remaining 980 messages were not checked to be junk or not.
Error Console:
gMessengerBundle is not defined
chrome://messenger/content/junkCommands.js   Line: 276


Expected results:

The whole folder should have been checked for junk.

Comment 1

6 years ago
I can confirm I'm getting this as well.
(Assignee)

Updated

6 years ago
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Summary: "Run Junk Mail Controls on Folder" quits early with error → "Run Junk Mail Controls on Folder" quits early with error gMessengerBundle is not defined chrome://messenger/content/junkCommands.js Line: 276

Comment 2

6 years ago
I'm also seeing this. Hopefully it will stay reproducible so I can track it down. I'm seeing it mostly on Mark/Run Junk Mail Controls
Assignee: nobody → kent
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

6 years ago
(In reply to Kent James (:rkent) from comment #2)
> I'm also seeing this. Hopefully it will stay reproducible so I can track it
> down. I'm seeing it mostly on Mark/Run Junk Mail Controls

My money is on an ill-advised NS_ENSURE_SUCCESS(rv, rv); ;-)
(Assignee)

Comment 4

6 years ago
Created attachment 580699 [details] [diff] [review]
fix

David, you could loose the money this time ;-)
This fixed it for me.
Attachment #580699 - Flags: review?(dbienvenu)
(Assignee)

Comment 5

6 years ago
Can somebody look at the patch?
This may even be nice for TB9/10. It should be really low risk for a high reward (unbreaking a function exposed in menu).

Comment 6

6 years ago
Comment on attachment 580699 [details] [diff] [review]
fix

thx very much for the patch; sorry for the delay.
Attachment #580699 - Flags: review?(dbienvenu) → review+

Updated

6 years ago
Keywords: checkin-needed
(Assignee)

Comment 7

6 years ago
This was a quick fix, however there is a comment at the top of the file, that gMessengerBundle is a global prerequisite.
It may be worth investigating why it is no longer defined here.
(Assignee)

Updated

6 years ago
Attachment #580699 - Flags: approval-comm-beta?
Attachment #580699 - Flags: approval-comm-aurora?
(Assignee)

Updated

6 years ago
Assignee: kent → acelists
Checked in: http://hg.mozilla.org/comm-central/rev/de32f9b38fea
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 11.0
Our junk command tests didn't catch this because they complete too soon for the statusDisplayInterval. :(
Comment on attachment 580699 [details] [diff] [review]
fix

a=Standard8 for Aurora, too late for TB 9.
Attachment #580699 - Flags: approval-comm-beta?
Attachment #580699 - Flags: approval-comm-beta-
Attachment #580699 - Flags: approval-comm-aurora?
Attachment #580699 - Flags: approval-comm-aurora+
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/962c4118375a
status-thunderbird10: --- → fixed
(In reply to Siddharth Agarwal [:sid0] from comment #9)
> Our junk command tests didn't catch this because they complete too soon for
> the statusDisplayInterval. :(

needs a follow up bug for tests?

http://getsatisfaction.com/mozilla_messaging/topics/run_junk_mail_controls_on_folder_mostly_inoperable_in_versions_6_7 reports this as happening at least as early as version 6

looks like this made the merge for v10 beta which is dated 12/22, correct?
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/10.0b1/win32/en-US/
Flags: in-testsuite?
Keywords: regression
(Assignee)

Comment 13

6 years ago
Per comment 10 and comment 11 this should be in TB 10 (Aurora at that time, now Beta). I asked for backport to sooner releases than TB11. TB9 didn't make it as it had only 1 day before release.
Whiteboard: [gs] → [gs][gssolved]
You need to log in before you can comment on or make changes to this bug.