Status

--
minor
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: nmaul, Assigned: nmaul)

Tracking

Details

(Assignee)

Description

7 years ago
Need to update Etherpad once more. This will be much smaller, though, and is mainly to pull in some new upstream features (delete public pads!) and some Mozilla-specific fixes (don't tell people to email us on problems, link them the itrequest Bugzilla form instead).

To do this, we should remove the Etherpad RPM and replace it with a git checkout of the repo I created for this: git://github.com/superawesome/pad.git

https://github.com/superawesome/pad

This repo is basically just a fork of the upstream Etherpad github repo, with Mozilla-specific fixes merged in.

The mana documentation should be updated to reflect how this works. Also, I have checked in a shell script to puppet, which should ultimately be useful for pulling and deploying a new version of Etherpad from this git repo. Needs some refinement, but it's a start.


There is another project on the horizon to add BrowserID support to Etherpad. When that gets underway, this git repo may move to the main mozilla github account... or some similar place where webdev can more easily maintain it.
(Assignee)

Updated

7 years ago
Assignee: server-ops → nmaul
(Assignee)

Updated

7 years ago
Duplicate of this bug: 697969
(Assignee)

Updated

7 years ago
Duplicate of this bug: 699712
(Assignee)

Comment 3

7 years ago
This will happen with the upcoming BrowserID rollout... our repo for that was forked from mine, which has these fixes.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.