keep-alive ignores ports

VERIFIED DUPLICATE of bug 51237

Status

()

--
major
VERIFIED DUPLICATE of bug 51237
18 years ago
16 years ago

People

(Reporter: gregw, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-ac20 i686; en-US; 0.8) Gecko/20010215
BuildID:    2001021503

If keep-alive support is on, then the port is ignored when selecting 
a connection. 

If I goto 1.2.3.4:8080/r1   and then try to goto 1.2.3.4:9090/r2, the
browser uses the kept alive connection of the first request to try
to get the second request.

Reproducible: Always
Steps to Reproduce:

Run two servers on the same machine on different ports.
Turn on keep-alive
type a URL on the first server.
type in a URL on the second server

Actual Results:  You get a response from the first server trying to locate the
resource you requested on the second server.

Expected Results:  The resource from the second server
Thos should be a dupe of 51237.
(Mozilla confuses multiple ports on same machine)


*** This bug has been marked as a duplicate of 51237 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.