Add support for alac (apple lossless audio codec) in <audio> and <video> elements

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Mardeg, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
from http://alac.macosforge.org/
"The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and supported on iPhone, iPad, most iPods, Mac and iTunes."
The Apache license may be incompatible with MPL?

Given the WONTFIX resolution on bug 586558 (with the possibility of reopening in future upon reconsideration) I'll do that with this one also.
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 1

7 years ago
I meant bug 586568 in comment 0
Duplicate of this bug: 697922
Why WONTFIX? For the same reasons as in bug 586568? Just curious.
I can't speak for kinetik, but in general the arguments are:

1) Any additional codec means more code to maintain, and
2) Codecs are a lot more useful if all major browsers implement them.

We're willing to fight for an open set of baseline codecs, and to support major formats when the licensing allows, but putting these arguments together we're not anxious to to be the first to support alac or flac among the browser vendors.
Re-opening as I see benefits to supporting ALAC.

One of the core issue in the discussion linked to above was the lack of support for the MP4 container which is now fully supported (and has been for almost 2 years)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Component: Audio/Video → Audio/Video: Playback
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.