Closed Bug 698007 Opened 13 years ago Closed 1 year ago

Rendering errors on long page

Categories

(Core :: Graphics, defect)

7 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: alameda+bugzilla, Unassigned)

References

()

Details

Attachments

(2 files)

Attached image cnetrenderfail.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

1. Go to http://www.cnet.com/ 
2. At the bottom of the "Latest on CNET" section, click the "Load more content" button
3. Repeat step 2, 6 or 7 times


Actual results:

The page rendering has major issues: 

- The background will turn black in random blocks
- Content will be randomly painted on top of each other


Expected results:

Page should render normally. Other browsers render this correctly.
Bug 692350 maybe
Attachment #570425 - Attachment mime type: text/plain → text/html
The cut off main background can be bug 671302. But the overlapping titles on the top I don't know.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Component: Layout → Layout: View Rendering
QA Contact: layout → layout.view-rendering
Works fine with D2D. I think this is just more cairo/pixman fail.
Status: UNCONFIRMED → NEW
Ever confirmed: true
2011-05-27 nightly works fine, 2011-05-28 nightly is broken. So likely cairo 1.10 upgrade, and probably the same as the very tall background bugs.
Blocks: 562746
Component: Layout: View Rendering → Graphics
QA Contact: layout.view-rendering → thebes
Severity: normal → S3

Unable to reproduce in current versions.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.