Closed Bug 698128 Opened 10 years ago Closed 4 years ago

String.localeCompare is broken on android

Categories

(Core :: DOM: Core & HTML, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1217790

People

(Reporter: mossop, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

Attached file testcase (obsolete) —
See the attached testcase. Try it on desktop Firefox and android Fennec. On desktop it correctly returns a negative number, on android it's positive.
Attached file testcase
Attachment #570376 - Attachment is obsolete: true
This depends on Bionic implemention, but we have land ICU support on all channel.  So dup of bug 1217790
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1217790
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.