Closed Bug 698220 Opened 8 years ago Closed 8 years ago

AwesomeBarTabs and content is not displayed on device rotation

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: aaronmt, Assigned: sriram)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Nightly (10/29)
Currently when one is idle in the AwesomeScreen and rotates ones device, all AwesomeBarTabs and content is removed from the screen and nothing is displayed.

See screenshot

Steps: 

1. Open the AwesomeScreen
2. Rotate device to landscape, and dismiss the virtual keyboard

D/AwesomeBar(  689): creating awesomebar
D/AwesomeBarTabs(  689): Creating AwesomeBarTabs
D/AwesomeBarTabs(  689): Creating All Pages tab
D/AwesomeBarTabs(  689): Creating Bookmarks tab
D/AwesomeBarTabs(  689): Creating History tab


The AwesomeBarTabs are created but nothing is displayed.

--
Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1) Gecko/20111029 Firefox/10.0a1 Fennec/10.0a1
HTC Nexus One (Android 2.3.6)
Assignee: nobody → sriram
Sriram says in channel that this is due to a trigger on rotation that starts filtering whatever content is in the url bar
Attached patch PatchSplinter Review
This patch fixes the issue by listening to orientation changes.
This patch also changes "text" to "mText" for the sake of consistency.
Attachment #570813 - Flags: review?(mark.finkle)
Comment on attachment 570813 [details] [diff] [review]
Patch

Seems OK. I don't have any reason to not use the | android:configChanges="orientation" | so let's do it.
Attachment #570813 - Flags: review?(mark.finkle) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This seems to be not landed yet. Could someone please land this?
20111103114449
http://hg.mozilla.org/projects/birch/rev/c1881e7e046c
Samsung Nexus S (Android 2.3.6)
Status: RESOLVED → VERIFIED
This was backed out because of test failures on an earlier push.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
backout was backed out https://hg.mozilla.org/projects/birch/rev/6f925b45a547
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
20111114041052
http://hg.mozilla.org/projects/birch/rev/859ecdfe0168
Samsung Galaxy SII (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.