Closed Bug 698375 Opened 13 years ago Closed 13 years ago

Dynamically generated MathML doesn't print correctly

Categories

(Core :: MathML, defect)

8 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 468568

People

(Reporter: lasdka88+mozbugs, Unassigned)

References

Details

Attachments

(2 files)

I tried to print a dynamically generated MathML equation.

The equation is correctly displayed on-screen. However, when I select print preview (and when I actually print the page) half the maths symbols are missing.

The printed equation should appear exactly as it appears on-screen.

I have a attached html two files, the first includes a single inline MathML equation. This prints correctly.
The second includes the same MathML equation, but this time it is dynamically generated from tex syntax via javascript using MathJax (http://www.mathjax.org/)

The two html files display correctly and identically on screen. However, only the inline MathML equation will print correctly. The dynamically generated one will not.

I've verified this behaviour on Ubuntu (Firefox v7) and Windows (Firefox v8 beta).
Component: General → MathML
Product: Firefox → Core
QA Contact: general → mathml
Attachment #570647 - Attachment mime type: text/plain → text/html
Attachment #570648 - Attachment mime type: text/plain → text/html
MathJax uses downloadable fonts, no?  Seems likely this is a duplicate of the bug on printing with those...

Particularly because I see the issue the _first_ time I print preview the page, but the second time it looks fine.
I had a quick search and found bug 468568. Yes. It's entirely possible that this behaviour is caused by this bug. I haven't installed any STIX fonts on either my Windows or linux boxes and when they are not available locally MathJax will attempt use downloadable fonts. However, to be sure it would be good to use the attached file to test with after bug 468568 has been fixed.

I'm not able to reproduce the behaviour that you claim whereby the equation displays correctly on subsequent attempts to print-preview the page though and I didn't read anything about that workaround in bug 468568 either.
Depends on: 468568
Just discovered that this is a duplicate of 687809.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
This is rather a duplicate of bug 468568.
No longer depends on: 468568
Depends on: 468568
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: