Closed Bug 698417 Opened 11 years ago Closed 9 years ago

Remove nsScriptObjectHolder's operator void *

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 850293

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Details

Attachments

(1 file)

Attached patch Patch v1Splinter Review
No description provided.
Attachment #570690 - Flags: review?(peterv)
Comment on attachment 570690 [details] [diff] [review]
Patch v1

Review of attachment 570690 [details] [diff] [review]:
-----------------------------------------------------------------

Can we remove nsDOMScriptObjectHolder? We have a stack scanner, so if we put the JSScript on the stack we don't really need it, right?
Comment on attachment 570690 [details] [diff] [review]
Patch v1

Waiting for reply on comment 1.
Attachment #570690 - Flags: review?(peterv) → review-
(In reply to Peter Van der Beken [:peterv] from comment #1)
> Comment on attachment 570690 [details] [diff] [review]
> Patch v1
> 
> Review of attachment 570690 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Can we remove nsDOMScriptObjectHolder?

Yep.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 850293
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.