Running Chatzilla [Tasks->Irc], causes crash.

VERIFIED DUPLICATE of bug 70072

Status

()

Core
DOM: Core & HTML
--
blocker
VERIFIED DUPLICATE of bug 70072
17 years ago
17 years ago

People

(Reporter: Jim Dunn, Assigned: karnaze (gone))

Tracking

({crash, testcase, topcrash})

Trunk
crash, testcase, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Using a build from today (yesterday's is fine) i am gettin a crash
lauching irc.
(Reporter)

Comment 1

17 years ago
Here is the traceback:

#0  0x7a2eb750 in  () from
/builds/jdunn/trunk/mozilla/obj-hppa-hp-hpux11.00/dist/bin/components/libgklayout.sl
#1  0x7a4f67d4 in nsTableFrame::GetFrameAtOrBefore (aPresContext=0x40a34088,
aParentFrame=0x40a5b92c, aPriorChildFrame=0x40a73cd0, aChildType=0x40116618) at
/builds/jdunn/trunk/mozilla/layout/html/table/src/nsTableFrame.cpp:4321
#2  0x7a4ef704 in nsTableFrame::InsertFrames (this=0x40a5b92c,
aPresContext=0x40a34088, aPresShell=@0x40a4e878, aListName=0x0,
aPrevFrame=0x40a73cd0, aFrameList=0x40a74338) at
/builds/jdunn/trunk/mozilla/layout/html/table/src/nsTableFrame.cpp:2453
#3  0x7a341d6c in FrameManager::InsertFrames (this=0x40a4f098,
aPresContext=0x40a34088, aPresShell=@0x40a4e878, aParentFrame=0x40a5b92c,
aListName=0x0, aPrevFrame=0x40a73cd0, aFrameList=0x40a74338) at
/builds/jdunn/trunk/mozilla/layout/html/base/src/nsFrameManager.cpp:797
#4  0x7a4a4258 in nsCSSFrameConstructor::ContentInserted (this=0x40a4e7c0,
aPresContext=0x40a34088, aContainer=0x40a6bd78, aChild=0x40a8b1e8,
aIndexInContainer=1, aFrameState=0x0) at
/builds/jdunn/trunk/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp:8592
#5  0x78956000 in StyleSetImpl::ContentInserted (this=0x40a4e6b0,
aPresContext=0x40a34088, aContainer=0x40a6bd78, aChild=0x40a8b1e8,
aIndexInContainer=1) at
/builds/jdunn/trunk/mozilla/content/base/src/nsStyleSet.cpp:1222
#6  0x7a3b1324 in PresShell::ContentInserted (this=0x40a4e878,
aDocument=0x409edce8, aContainer=0x40a6bd78, aChild=0x40a8b1e8,
aIndexInContainer=1) at /builds/jdunn/trunk/mozilla/layout/html/base/src/nsPresSh
ell.cpp:4288
#7  0x788890d8 in nsDocument::ContentInserted (this=0x409edce8,
aContainer=0x40a6bd78, aChild=0x40a8b1e8, aIndexInContainer=1) at
/builds/jdunn/trunk/mozilla/content/base/src/nsDocument.cpp:1619
#8  0x78658edc in nsHTMLDocument::ContentInserted (this=0x409edce8,
aContainer=0x40a6bd78, aChild=0x40a8b1e8, aIndexInContainer=1) at
/builds/jdunn/trunk/mozilla/content/html/document/src/nsHTMLDocument.cpp:1322
#9  0x78563b3c in nsGenericHTMLContainerElement::InsertChildAt (this=0x40a6bd78,
aKid=0x40a8b1e8, aIndex=1, aNotify=1) at
/builds/jdunn/trunk/mozilla/content/html/content/src/nsGenericHTMLElement.cpp:3409
#10 0x788efe54 in nsGenericElement::doInsertBefore (this=0x40a6bd78,
aNewChild=0x40a8b214, aRefChild=0x0, aReturn=0x7b042980) at
/builds/jdunn/trunk/mozilla/content/base/src/nsGenericElement.cpp:2275
#11 0x789b1dc4 in nsHTMLTableElement::AppendChild (this=0x40a6bd78,
aNewChild=0x40a8b214, aReturn=0x7b042980) at
/builds/jdunn/trunk/mozilla/content/html/content/src/nsHTMLTableElement.cpp:60
#12 0x79d3a4c0 in NodeAppendChild (cx=0x408ee2a0, obj=0x40967e80, argc=1,
argv=0x40a69874, rval=0x7b0427ac) at
/builds/jdunn/trunk/mozilla/dom/src/coreDOM/nsJSNode.cpp:593
#13 0x7abe19b0 in js_Invoke (cx=0x408ee2a0, argc=1, flags=0) at
/builds/jdunn/trunk/mozilla/js/src/jsinterp.c:777
#14 0x7abf5ec0 in js_Interpret (cx=0x408ee2a0, result=0x7b042270) at
/builds/jdunn/trunk/mozilla/js/src/jsinterp.c:2670
#15 0x7abe1a74 in js_Invoke (cx=0x408ee2a0, argc=0, flags=0) at
/builds/jdunn/trunk/mozilla/js/src/jsinterp.c:794
#16 0x7abf5ec0 in js_Interpret (cx=0x408ee2a0, result=0x7b041bb4) at
/builds/jdunn/trunk/mozilla/js/src/jsinterp.c:2670
#17 0x7abe2644 in js_Execute (cx=0x408ee2a0, chain=0x4069e220,
script=0x406d8d48, down=0x0, special=0, result=0x7b041bb4) at
/builds/jdunn/trunk/mozilla/js/src/jsinterp.c:956
#18 0x7ab9b000 in JS_EvaluateUCScriptForPrincipals (cx=0x408ee2a0,
obj=0x4069e220, principals=0x401f66a4, chars=0x7b041890, length=10,
filename=0x4080c628 "chrome://chatzilla/content/static.js", lineno=384, r
val=0x7b041bb4) at /builds/jdunn/trunk/mozilla/js/src/jsapi.c:3221
#19 0x79c78f20 in nsJSContext::EvaluateString (this=0x408ecfb0,
aScript=@0x7b041878, aScopeObject=0x4069e220, aPrincipal=0x401f66a0,
aURL=0x4080c628 "chrome://chatzilla/content/static.js", aLineNo=384,
aVersion=0x7ab47c58 "default", aRetValue=@0x7b041910, aIsUndefined=0x7b0419f0)
at /builds/jdunn/trunk/mozilla/dom/src/base/nsJSEnvironment.cpp:602
#20 0x79cdf3b4 in GlobalWindowImpl::RunTimeout (this=0x408ee020,
aTimeout=0x40810198) at
/builds/jdunn/trunk/mozilla/dom/src/base/nsGlobalWindow.cpp:3921
#21 0x79ce0d7c in nsGlobalWindow_RunTimeout (aTimer=0x4080c7f8,
aClosure=0x40810198) at
/builds/jdunn/trunk/mozilla/dom/src/base/nsGlobalWindow.cpp:4204
#22 0x775cc1d4 in nsTimerGtk::FireTimeout (this=0x4080c7f8) at
/builds/jdunn/trunk/mozilla/widget/timer/src/unix/gtk/nsTimerGtk.cpp:183
#23 0x775cc6d4 in process_timers (array=0x401da638) at
/builds/jdunn/trunk/mozilla/widget/timer/src/unix/gtk/nsTimerGtk.cpp:256
#24 0x775cc850 in TimerCallbackFunc (data=0x0) at
/builds/jdunn/trunk/mozilla/widget/timer/src/unix/gtk/nsTimerGtk.cpp:283
#25 0x795e712c in ?? () from /opt/glib/lib/libglib.sl
#26 0x795e5ca4 in ?? () from /opt/glib/lib/libglib.sl
#27 0x795e62a0 in ?? () from /opt/glib/lib/libglib.sl
#28 0x795e66e8 in ?? () from /opt/glib/lib/libglib.sl
#29 0x794b5df8 in ?? () from /opt/gtk+/lib/libgtk.sl
#30 0x797ee1f8 in nsAppShell::Run (this=0x400559b0) at
/builds/jdunn/trunk/mozilla/widget/src/gtk/nsAppShell.cpp:350
#31 0x799f5850 in nsAppShellService::Run (this=0x4004eef0) at
/builds/jdunn/trunk/mozilla/xpfe/appshell/src/nsAppShellService.cpp:407
#32 0x198a4 in main1 (argc=1, argv=0x7b040eec, nativeApp=0x0) at
/builds/jdunn/trunk/mozilla/xpfe/bootstrap/nsAppRunner.cpp:978
#33 0x1cc3c in main (argc=1, argv=0x7b040eec) at
/builds/jdunn/trunk/mozilla/xpfe/bootstrap/nsAppRunner.cpp:1270


Summary: Running Tasts->irc, causes crash. → Running Tasks->Irc, causes crash.
(Reporter)

Comment 2

17 years ago
I put the following change in, and I no longer crash
but looking at the code, am not sure if this is the correct fix.

Index: nsTableFrame.cpp
===================================================================
RCS file: /cvsroot/mozilla/layout/html/table/src/nsTableFrame.cpp,v
retrieving revision 3.417
diff -u -r3.417 nsTableFrame.cpp
--- nsTableFrame.cpp    2001/02/07 09:56:35     3.417
+++ nsTableFrame.cpp    2001/02/22 21:06:47
@@ -4317,7 +4317,7 @@
   nsIFrame* childFrame;
   nsIFrame* lastMatchingFrame = nsnull;
   aParentFrame->FirstChild(aPresContext, nsnull, &childFrame);
-  while (childFrame != aPriorChildFrame) {
+  while (childFrame && (childFrame != aPriorChildFrame)) {
     childFrame->GetFrameType(&frameType);
     if (aChildType == frameType) {
       lastMatchingFrame = childFrame;

Comment 3

17 years ago
With the indicated patch, chatzilla now starts, but still crashes at various
times.  Here's a partial stack trace:

#0  0x39 in ?? ()
#1  0x40b49278 in nsXULTemplateBuilder::RemoveMember ()
   from /usr/src/mozilla/dist/bin/components/libgkcontent.so
#2  0x40b459dc in nsXULTemplateBuilder::Retract ()
   from /usr/src/mozilla/dist/bin/components/libgkcontent.so
#3  0x40b52061 in nsXULTemplateBuilder::OnUnassert ()
   from /usr/src/mozilla/dist/bin/components/libgkcontent.so
#4  0x40873fdb in CompositeDataSourceImpl::OnUnassert ()
   from /usr/src/mozilla/dist/bin/components/librdf.so
#5  0x40875932 in InMemoryDataSource::Unassert ()
   from /usr/src/mozilla/dist/bin/components/librdf.so
#6  0x400e00e8 in XPTC_InvokeByIndex ()
   from /usr/src/mozilla/dist/bin/libxpcom.so
#7  0x407f3b78 in nsXPCWrappedNativeClass::CallWrappedMethod ()
   from /usr/src/mozilla/dist/bin/components/libxpconnect.so
#8  0x407f5461 in WrappedNative_CallMethod ()
   from /usr/src/mozilla/dist/bin/components/libxpconnect.so
#9  0x40153f1a in js_Invoke () from /usr/src/mozilla/dist/bin/libmozjs.so
#10 0x4015b0b8 in js_Interpret () from /usr/src/mozilla/dist/bin/libmozjs.so
#11 0x401543f9 in js_Execute () from /usr/src/mozilla/dist/bin/libmozjs.so
#12 0x40128d17 in JS_EvaluateUCScriptForPrincipals ()
   from /usr/src/mozilla/dist/bin/libmozjs.so
#13 0x4046a9f7 in nsJSContext::EvaluateString ()
   from /usr/src/mozilla/dist/bin/libjsdom.so
#14 0x404871dd in GlobalWindowImpl::RunTimeout ()
   from /usr/src/mozilla/dist/bin/libjsdom.so
#15 0x4048ca44 in nsGlobalWindow_RunTimeout ()
   from /usr/src/mozilla/dist/bin/libjsdom.so
#16 0x407ade8e in process_timers ()
   from /usr/src/mozilla/dist/bin/components/libtimer_gtk.so
#17 0x407aeb2c in TimerCallbackFunc ()
   from /usr/src/mozilla/dist/bin/components/libtimer_gtk.so
#18 0x406cf04d in g_timeout_dispatch () from /usr/lib/libglib-1.2.so.0

BTW this is on Linux, so it would be good if someone can test on Windows

Comment 4

17 years ago
chris, any ideas?
*** Bug 70051 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
It's still crashing Mo on load with NT.  It isn't intermittent.

Updated

17 years ago
Keywords: crash
OS: HP-UX → All
Hardware: HP → All

Updated

17 years ago
Severity: normal → blocker

Comment 7

17 years ago
Over to jst in DOM land.  This isn't a problem with the chatzilla code.

I'll file another bug on the template crash.

jst: This worked fine before the 22nd.  I made a testcase that creates a table
and inserts a row with two columns in it (which is what chatzilla is doing at
about the time of the crash), and it works fine.  Maybe some interaction with
the css?
Assignee: rginda → jst
Component: chatzilla → DOM Level 0
I tried to reproduce this but I was unable to, looks like the crash is in table
reflow code so over to karnaze for futher investigation.
Assignee: jst → karnaze

Comment 9

17 years ago
*** Bug 70356 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
my bug 70356 just got marked dup on this one, adding self to cc:
also note that "crashzilla"* incident ID TB27026251H is this problem.

(* hey, it's a better name than "Netscape Quality Feedback Agent")

Comment 11

17 years ago
here;'s another (partial stack trace from bug 70512) Adding topcrash keyword as 
per comments by Phil in bug 70361 (number of time reported: 29...number 6 on 
the list)

 nsTableFrame::GetFrameAtOrBefore  
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 4325]
     nsTableRowFrame::InsertFrames
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
237]
     FrameManager::InsertFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 799]
     nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8614]
     StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1224]
     PresShell::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4290]
     nsVoidArray::ElementAt
[d:\builds\seamonkey\mozilla\xpcom\ds\nsVoidArray.cpp, line 126]
     nsHTMLDocument::ContentInserted
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp, line
1323]
     nsHTMLDocument::ContentInserted
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp, line
1323]
Keywords: topcrash

Comment 12

17 years ago
*** Bug 70512 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 70589 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 70604 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
Shouldn't the "Component" be changed to Chatzilla, else than the current DOM
Level 0? Or that the word "chatzilla" be added to the summary, fields? I just
filled a bug report, because I didn't find any bugs...

Updated

17 years ago
Summary: Running Tasks->Irc, causes crash. → Running Chatzilla [Tasks->Irc], causes crash.

Comment 16

17 years ago
gotcha, I found a reproducible testcase while running the table regression
tests. see (crash at) URL.
Keywords: mozilla0.8.1, testcase

Comment 17

17 years ago
The patch is insufficient, it fixes the crash, but the URL does not layout correct.

Comment 18

17 years ago
*** Bug 70971 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago

*** This bug has been marked as a duplicate of 70072 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 21

17 years ago
Running IRC is crashing again, (20010320 own build Windows Me) may be a
different 1 all together, but i suggest reopening this 1. Following reproduce
steps from 70072 doesn't cause a crash.

Comment 22

17 years ago
That was bug 72614, which is now fixed.
You need to log in before you can comment on or make changes to this bug.