Semi-Hang after switching networks and then closing a window.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

10 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 570793 [details]
sample process during semi-hang

I ended up moving my computer from Zombocom to my desk and it switched my network status from on to off and back on again.  Closed a window and the browser hung.  

Built from http://hg.mozilla.org/mozilla-central/rev/04b4ea333800
Build platform
target
x86_64-apple-darwin10
on Mac OS X 10.6.8

Main Process

Explicit Allocations
527.42 MB (100.0%) -- explicit
├──213.24 MB (40.43%) -- heap-unclassified
├──206.67 MB (39.19%) -- js
│  ├───47.97 MB (09.10%) -- compartment([System Principal], 0x117cf7000)
│  │   ├──33.66 MB (06.38%) -- gc-heap
│  │   │  ├──17.14 MB (03.25%) -- objects
│  │   │  │  ├──12.64 MB (02.40%) -- function
│  │   │  │  └───4.50 MB (00.85%) -- non-function
│  │   │  ├──12.17 MB (02.31%) -- shapes
│  │   │  │  ├───9.85 MB (01.87%) -- tree
│  │   │  │  └───2.33 MB (00.44%) -- (1 omitted)
│  │   │  └───4.34 MB (00.82%) -- (5 omitted)
│  │   ├───9.58 MB (01.82%) -- (8 omitted)
│  │   └───4.74 MB (00.90%) -- shapes-extra
│  │       ├──3.05 MB (00.58%) -- tree-tables
│  │       └──1.68 MB (00.32%) -- (3 omitted)
│  ├───30.86 MB (05.85%) -- gc-heap-chunk-dirty-unused
│  ├───28.93 MB (05.49%) -- compartment(https://bugzilla.mozilla.org/show_bug.cgi?id=694987)
│  │   ├──16.48 MB (03.12%) -- gc-heap
│  │   │  ├───7.44 MB (01.41%) -- objects
│  │   │  │   ├──4.90 MB (00.93%) -- function
│  │   │  │   └──2.53 MB (00.48%) -- (1 omitted)
│  │   │  ├───5.24 MB (00.99%) -- shapes
│  │   │  │   ├──4.54 MB (00.86%) -- tree
│  │   │  │   └──0.70 MB (00.13%) -- (1 omitted)
│  │   │  └───3.81 MB (00.72%) -- (4 omitted)
│  │   ├───4.54 MB (00.86%) -- (5 omitted)
│  │   ├───4.19 MB (00.79%) -- mjit-code
│  │   │   ├──3.95 MB (00.75%) -- method
│  │   │   └──0.24 MB (00.04%) -- (2 omitted)
│  │   └───3.72 MB (00.71%) -- script-data
│  ├───20.08 MB (03.81%) -- compartment(https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-10-31%2006%3A00%3A00&signature=nsHtml5Tokenizer%3A%3AstateLoop%28int%2C%20wchar_t%2C%20int%2C%20wchar_t%2A%2C%20bool%2C%20int%2C%20int%29&version=Fennec%3A10.0a1)
│  │   ├──10.47 MB (01.98%) -- gc-heap
│  │   │  ├───6.22 MB (01.18%) -- (5 omitted)
│  │   │  └───4.24 MB (00.80%) -- objects
│  │   │      └──4.24 MB (00.80%) -- (2 omitted)
│  │   ├───5.48 MB (01.04%) -- (6 omitted)
│  │   └───4.13 MB (00.78%) -- mjit-code
│  │       ├──3.83 MB (00.73%) -- method
│  │       └──0.29 MB (00.06%) -- (2 omitted)
│  ├───19.63 MB (03.72%) -- compartment(https://docs.google.com/spreadsheet/ccc?key=0Arku3jleCA0UdDdOWWxBdU5hSDNQMkRzbGs5TVA2Q0E&hl=en_US#gid=4)
│  │   ├──11.65 MB (02.21%) -- gc-heap
│  │   │  ├───7.34 MB (01.39%) -- (5 omitted)
│  │   │  └───4.31 MB (00.82%) -- objects
│  │   │      └──4.31 MB (00.82%) -- (2 omitted)
│  │   └───7.98 MB (01.51%) -- (8 omitted)
│  ├───10.34 MB (01.96%) -- compartment(http://graphs-new.mozilla.org/graph.html#tests=[[16,27,20],[16,52,20],[16,63,20]]&sel=none&displayrange=7&datatype=running)
│  │   ├───6.60 MB (01.25%) -- gc-heap
│  │   │   └──6.60 MB (01.25%) -- (6 omitted)
│  │   └───3.74 MB (00.71%) -- (7 omitted)
│  ├────9.59 MB (01.82%) -- compartment(http://www.google.com/reader/view/#stream/user%2F12217816968448464054%2Flabel%2F..Firefox)
│  │    ├──6.03 MB (01.14%) -- gc-heap
│  │    │  └──6.03 MB (01.14%) -- (6 omitted)
│  │    └──3.56 MB (00.68%) -- (7 omitted)
│  ├────9.24 MB (01.75%) -- compartment(https://plus.google.com/u/0/_/notifications/frame?hl=en&origin=http%3A%2F%2Fwww.google.com&jsh=r%3Bgc%2F23980661-3686120e#pid=32&id=gbsf&parent=http%3A%2F%2Fwww.google.com&rpctoken=702190450&_methods=onError%2ConInfo%2ChideNotificationWidget%2CpostSharedMessage%2CsetNotificationWidgetHeight%2CswitchTo%2CnavigateTo%2CsetNotificationText%2ChandlePosted%2C_ready%2C_close%2C_open%2C_resizeMe)
│  │    ├──5.37 MB (01.02%) -- gc-heap
│  │    │  └──5.37 MB (01.02%) -- (6 omitted)
│  │    └──3.87 MB (00.73%) -- (7 omitted)
│  ├────8.00 MB (01.52%) -- stack
│  ├────7.07 MB (01.34%) -- (9 omitted)
│  ├────6.43 MB (01.22%) -- compartment(https://etherpad.mozilla.org/fennec-perf-ts-take2)
│  │    ├──3.38 MB (00.64%) -- (8 omitted)
│  │    └──3.05 MB (00.58%) -- gc-heap
│  │       └──3.05 MB (00.58%) -- (6 omitted)
│  ├────4.26 MB (00.81%) -- compartment(https://wiki.mozilla.org/QA/Fennec/crash_rep_28Oct2011)
│  │    └──4.26 MB (00.81%) -- (8 omitted)
│  └────4.26 MB (00.81%) -- compartment(atoms)
│       ├──2.76 MB (00.52%) -- gc-heap
│       │  ├──2.71 MB (00.51%) -- strings
│       │  └──0.05 MB (00.01%) -- (1 omitted)
│       └──1.50 MB (00.28%) -- (1 omitted)
├───48.77 MB (09.25%) -- layout
│   ├──28.10 MB (05.33%) -- (33 omitted)
│   ├──17.81 MB (03.38%) -- shell(chrome://browser/content/browser.xul)
│   │  ├──11.87 MB (02.25%) -- arenas [22]
│   │  ├───5.94 MB (01.13%) -- styledata [22]
│   │  └───0.00 MB (00.00%) -- (1 omitted)
│   └───2.86 MB (00.54%) -- shell(https://docs.google.com/spreadsheet/ccc?key=0Arku3jleCA0UdDdOWWxBdU5hSDNQMkRzbGs5TVA2Q0E&hl=en_US#gid=4)
│       └──2.86 MB (00.54%) -- (2 omitted)
├───29.65 MB (05.62%) -- dom
├───11.73 MB (02.22%) -- storage
│   └──11.73 MB (02.22%) -- sqlite
│      ├───8.63 MB (01.64%) -- places.sqlite
│      │   ├──8.22 MB (01.56%) -- cache-used [3]
│      │   └──0.42 MB (00.08%) -- (2 omitted)
│      └───3.10 MB (00.59%) -- (12 omitted)
├────6.28 MB (01.19%) -- network-memory-cache
├────5.39 MB (01.02%) -- images
│    ├──5.15 MB (00.98%) -- content
│    │  ├──5.15 MB (00.98%) -- used
│    │  │  ├──4.82 MB (00.91%) -- uncompressed-heap
│    │  │  └──0.34 MB (00.06%) -- (2 omitted)
│    │  └──0.00 MB (00.00%) -- (1 omitted)
│    └──0.24 MB (00.04%) -- (1 omitted)
├────3.77 MB (00.71%) -- spell-check
└────1.92 MB (00.36%) -- (5 omitted)

Other Measurements
    7.62 MB -- canvas-2d-pixel-bytes
    5.25 MB -- gfx-surface-image
  360.14 MB -- heap-allocated
  376.68 MB -- heap-committed
      4.38% -- heap-committed-unallocated-fraction
    3.51 MB -- heap-dirty
   64.85 MB -- heap-unallocated
          2 -- js-compartments-system
         14 -- js-compartments-user
  133.00 MB -- js-gc-heap
   11.06 MB -- js-gc-heap-arena-unused
    0.00 MB -- js-gc-heap-chunk-clean-unused
   30.86 MB -- js-gc-heap-chunk-dirty-unused
     31.52% -- js-gc-heap-unused-fraction
    2.24 MB -- js-total-analysis-temporary
   18.84 MB -- js-total-mjit
   48.17 MB -- js-total-objects
   25.45 MB -- js-total-scripts
   36.99 MB -- js-total-shapes
    8.21 MB -- js-total-strings
    8.61 MB -- js-total-type-inference
     32,520 -- page-faults-hard
  1,841,681 -- page-faults-soft
  598.50 MB -- resident
4,556.29 MB -- vsize


Closed windows:
https://bugzilla.mozilla.org/show_bug.cgi?id=696804
https://bugzilla.mozilla.org/show_bug.cgi?id=698018
https://bugzilla.mozilla.org/show_bug.cgi?id=696213

This might be invalid?  Semi-hang = hang like state of unresponsiveness.  After going to lunch and coming back, the browser became responsive again.
This doesn't look like a zombie compartment or a MemShrink bug in general.
Whiteboard: [MemShrink]
retitling based on comment 1
Summary: Semi-Hang/Possible zombie compartment after switching networks and then closing a window. → Semi-Hang after switching networks and then closing a window.
Assignee: general → nobody
Does this still reproduce?
Flags: needinfo?(nhirata.bugzilla)
I don't so.  Closing as WFM.  It's hard to tell since I switched computers, upgraded OS, on top of the browser being updated since that time...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.