If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[10.7] Performing a two-finger scroll on a <select>'s <option> list causes the list to sporadically disappear on Mac OS X Lion.

RESOLVED DUPLICATE of bug 677279

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 677279
6 years ago
6 years ago

People

(Reporter: Steve Mokris, Unassigned)

Tracking

7 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 570829 [details]
option-scroll-lion.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

If a <select> box appears within a scrollable area (whether a <div style="overflow:scroll"> or just the normal full-page scrollbar), and the <select> box has enough <option>s that its dropdown also has a scrollbar, the dropdown list sporadically disappears while attempting to scroll it (using the standard Mac two-finger scroll gesture).

I found a similar bug, #644427, but this issue is happening for me on a clean Firefox 7.0.1 install, with no add-ons, so I'm opening another bug.


Actual results:

- Load attached HTML file in Firefox 7.0.1 on Lion (Mac OS 10.7.2).
- Click the <select> list (currently showing the word "alpha").  A list of options appears.
- Move the mouse inside the option list.
- Scroll using the two-finger gesture.
- After a second or two of scrolling, the option list disappears, and the scroll events are passed on to the containing element.  This makes navigation really difficult.

I first noticed this happening after upgrading to Lion (Mac OS 10.7.0).


Expected results:

<select>'s <option> list should remain visible until I dismiss it by clicking.  Scroll events should not dismiss it.
Summary: Performing a two-finger scroll on a <select>'s <option> list causes the list to sporadically disappear on Mac OS X Lion. → [10.7] Performing a two-finger scroll on a <select>'s <option> list causes the list to sporadically disappear on Mac OS X Lion.
Steve: I tried testing this with a clean profile using  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:7.0.1) Gecko/20100101 Firefox/7.0.1 but I haven't been able to reproduce the issue.
(Reporter)

Comment 2

6 years ago
(In reply to Marcia Knous [:marcia] from comment #1)
> Steve: I tried testing this with a clean profile using  Mozilla/5.0
> (Macintosh; Intel Mac OS X 10.7; rv:7.0.1) Gecko/20100101 Firefox/7.0.1 but
> I haven't been able to reproduce the issue.

Thanks for testing, Marcia.

Are you testing on 10.7.2 (the User Agent string just says "10.7")?

Are you testing using the trackpad in a recent MacBook Pro?  (I'm experiencing the issue on a "MacBookPro5,2" (mid-2009 model).)

I'll try it on a few other 10.7.2 workstations.
Steve: Yes, using 10.7.2 Build 11C74.

Actually I have an older Macbook Pro, 15 inch Mid 2009 model as well.
This sounds like bug 677279, which was fixed for Firefox 8. Steve, can you test whether this still happens for you with a Beta build?

http://www.mozilla.org/en-US/firefox/channel/
(Reporter)

Comment 5

6 years ago
@marcia:  Strange that you're not experiencing it on almost the same hardware and software.  For me, sometimes it requires flicking back and forth a few times before it disappears; other times, it happens as soon as I begin to scroll.  Thanks again.

@markus:  Ah!  Bug 677279 sounds plausibly like this problem, and upgrading to Firefox 8 does indeed solve the problem for me.  Closing my bug as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 677279
You need to log in before you can comment on or make changes to this bug.