If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"You can't dereference a NULL nsCOMPtr with operator->()." assertion on linux 64 debug test run

RESOLVED DUPLICATE of bug 689291

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 689291
6 years ago
6 years ago

People

(Reporter: myk, Assigned: ejpbruel)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
A recent Jetpack test run <https://tbpl.mozilla.org/?tree=Jetpack&usetinderbox=1&rev=b748278f0486> caused a Linux 64 debug build to fail with the assertion "###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().: 'mRawPtr != 0', file ../../dist/include/nsCOMPtr.h, line 849".

http://tinderbox.mozilla.org/showlog.cgi?tree=Jetpack&errorparser=unix&logfile=1320095820.1320096138.28401.gz&buildtime=1320095820&buildname=jetpack-mozilla-central-fedora64-debug&fulltext=1
(Assignee)

Updated

6 years ago
Assignee: nobody → ejpbruel
(Assignee)

Comment 1

6 years ago
I've set up a 64-bit Linux environment, but being unfamiliar with tinderbox output, I have no idea which test in which package is causing this bug. I need an exact sequence of steps to reproduce this bug locally.
(Reporter)

Comment 2

6 years ago
The short version is:

  git clone git://github.com/mozilla/addon-sdk.git
  cd addon-sdk
  source bin/activate
  cfx testall --binary /path/to/debug/build/dist/bin/firefox

Detailed instructions (including how to attach a debugger) are available on <https://wiki.mozilla.org/Jetpack/Testing>.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689291
No longer blocks: 697775
You need to log in before you can comment on or make changes to this bug.