If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
--
minor
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: glob, Assigned: jakem)

Tracking

Details

(Reporter)

Description

6 years ago
if you open http://videos.mozilla.org/serv you are redirected to http://videos-origin.mozilla.org/serv/

this probably shouldn't be happening; people may not realise they have been shifted to -origin, and share the -origin url instead of the cdn one.
(Assignee)

Comment 1

6 years ago
http://videos.mozilla.org/serv/ does not redirect
http://videos.mozilla.org/serv (missing trailing slash) does.

This is caused by the Apache DirectorySlash option, which redirects from pages missing the trailing slash to include it. It's on by default, for good reasons.

The problem is that the CDN sends its requests to videos-origin.mozilla.org... so that's what our server responds with. The CDN doesn't know to translate the redirect in the response, so it just sends it along to the end user.


There are several ways to fix this. I think what I'll do is tell the CDN to send requests with a Host header of 'videos-cdn.mozilla.net', and continue to let it pass back the response unmangled. Of course the request itself will still go to videos-origin.mozilla.org, only the Host header will change.

I've added this to ServerAlias on the origin server, just waiting on puppet to propagate before changing the setting on the CDN.
Assignee: nobody → nmaul
Component: Other → Server Operations: Web Operations
OS: Android → All
Product: Websites → mozilla.org
QA Contact: other → cshields
Version: unspecified → other
(Assignee)

Comment 2

6 years ago
Puppet propagated
Apache reloaded
CDN setting updated... waiting for propagation (up to 1 hr)


I have also changed DNS for videos-cdn.mozilla.net, but that's for a different bug (Bug 665620). I have verified that the setting in that place is correct as well.
(Assignee)

Comment 3

6 years ago
This is fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.