Export of a recurring item to ics creates incorrect RRULE entry

RESOLVED INVALID

Status

Calendar
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Tom Russell, Unassigned)

Tracking

Lightning 1.0b7

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 570994 [details]
recurring_event.ics

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

I exported a 15 day recurring item.  The ICS file created was interpreted as 15 weeks.  The RRULE created was "RRULE:FREQ=WEEKLY;COUNT=15;BYDAY=MO,TU,WE,TH,FR" 




Actual results:

When I imported this into egroupware, I got a 15 week event with a meeting every day.  


Expected results:

When I accepted the original invitation (from Outlook) it went on my Lightning calendar as 15 days.  It seems to me that the RRULE should have been FREQ=DAILY.

Comment 1

6 years ago
Created attachment 572009 [details]
modified ics

I had to add a BEGIN/END:VCALENDAR to the file for Lightning to be able to import it.

The attached file can be imported to Lightning.

Comment 2

6 years ago
Created attachment 572010 [details]
screenshot of imported file

I have imported the file into a local clendar and I think what I see corresponds to http://www.kanzaki.com/docs/ical/rrule.html.

Tom could you clarify what does not work. I have a daily event now which repeats on all weekdays ....
(Reporter)

Comment 3

6 years ago
Sorry for the delay.  I couldn't logon to bugzilla from Firefox 7.0.1.  I changed the password several times and always got a "userID invalid" when I tried to logon.  

So.  I tried IE and here I am.  

Sorry about the bug entry.  I exported my Lightning calendar, and imported it into eGroupware, because we are trying to get the company to use a shared calendar. The recurring item I extracted from the exported ics file was interpreted by eGroupware as a 15 week recurring item.  I repeated your test of importing the item into Lightning, and it does indeed only book 15 days.  So I will open a problem with eGroupware.   Sorry for the trouble. 
Thanks, Tom
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.