Firefox 8 beta fails without error to run some javascript (www.gucci.com)

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: mgolden, Unassigned)

Tracking

({regression})

8 Branch
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111026191032

Steps to reproduce:

Visit http://www.gucci.com/us/home on FF8.  On the very top right is a link marked search.  Click on this.


Actual results:

Nothing is displayed.


Expected results:

There is an overlay (a hidden div) which is supposed to show.  Note that this works properly in all other browsers (including FF7 and below).

I see an error showing up in firebug, but this is always present and does not seem to have anything to do with this problem.  Other than that, there is no indication of anything going wrong.

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
works on winXP
Summary: Firefox 8 beta fails without error to run some javascript → Firefox 8 beta fails without error to run some javascript (www.gucci.com)

Updated

7 years ago
Keywords: regression

Comment 2

7 years ago
Seems to work in FF7 and FF10 on Win XP.
As you seem to have extensions, have you tried Firefox safe mode?
https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 3

7 years ago
You're right.  It seems to be ghostery that breaks it.  This is odd because it never broke it before FF8.  I will file this bug on ghostery's site.  (And I won't report any more bugs without trying safe mode!)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 4

7 years ago
Yes, you should always test in safe mode first.
But that doesn't mean the is no bug in Firefox, the extension may just trigger it. So tell us what ghostery authors say to you. And reopen this bug if they claim it really is a bug in Firefox. But they should tell which functions they are calling in core Firefox that fail.
You need to log in before you can comment on or make changes to this bug.