Filters: To, CC, To or CC criteria matches only 1st in hdr line

VERIFIED WORKSFORME

Status

MailNews Core
Filters
P1
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: laurel, Assigned: gayatrib)

Tracking

Trunk
mozilla0.9
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

17 years ago
Using feb22 commercial trunk build
Seen with linux and win98, assume mac, too


A filter whose criteria is based on header criteria To:, Cc:, To or Cc: will
fail if the matching string appears in any but the first header of that type. 
Filter is not using "begins with", but will match a partial string in the said
header field as long as it is within the first address of the To: or CC: header
line when multiple addressees appear in that header line.  If the second To: or
second Cc: address is that which matches, the filter will not fire.

Seen on IMAP accounts, haven't tried POP yet.

Steps:
1.  Open mail to IMAP account, login.
2.  Edit|Message Filters.  Select the IMAP account and set up a simple filter
like this:  
    Criteria -- To:  contains llarue@netscape.com
    Action --  set priority to High  (I tried both priority and MoveToFolder
filters, didn't matter)
    Confirm OK to filter addition, confirm OK out of main filter dialog.
3.  Send the IMAP account a message addressed with llarue as 2nd To addressee:
    To:  laurel@netscape.com
    To:  llarue@netscape.com
4.  Get that message -- filter doesn't fire.
5.  Send the IMAP account a message addressed with llarue as the 1st of 2 To
addressees:
    To:  llarue@netscape.com
    To:  laurel@netscape.com
6.  Get that message -- filter fires.
7.  Repeat this a few times, notice it behaves same each time.

Note:  Same thing happens choosing criteria CC: or To or Cc:
(Reporter)

Updated

17 years ago
Keywords: nsbeta1
Priority: -- → P1
QA Contact: esther → laurel
(Reporter)

Comment 1

17 years ago
Applies to POP, too.

Comment 2

17 years ago
*** Bug 69965 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
*** Bug 70145 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
marking nsbeta1+ and moving to mozilla0.9. cc'ing bienvenu.
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9

Comment 5

17 years ago
I'd generate a protocol log and see if we're actually getting told about the
multiple to: addresses - my guess is not.

Comment 6

17 years ago
Laurel, is this still happening to you?  I tried this with 2001032104 on Win2000
and it seems to be working.
(Reporter)

Comment 7

17 years ago
This is generally working with mar28 commercial build. Will mark worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
Marking verified worksforme (apr18 commercial trunk)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.