Multiple saved usernames stymie password autofill

RESOLVED DUPLICATE of bug 376668

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 376668
7 years ago
7 years ago

People

(Reporter: erik, Unassigned)

Tracking

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Sometimes, multiple username/password pairs are stored for a single site. In particular, I ran into this with my shoeboxed.com account: FF had remembered both my initial automatically generated un/pw and the one I set manually after logging in for the first time.

For weeks I've thought shoeboxed.com was intentionally foiling FF's password saving, since the login form would always come up blank. Today, however, I realized that, when FF has more than 1 un/pw pair stored for a site, it simply throws up its hands.

What FF should do instead is just pick one: ideally the most recently used (or created, or whatever we have around). The current behavior is surprising and misleading.

Caveat: true, if you start typing the desired username, the corresponding password autofills, but I can't always guess what I used for a username, especially with today's profusion of email addresses which are increasingly used as login identifiers. With my suggested change, support for multiple accounts can remain, with the autofilled password changing if the user manually edits the username field.

This bug may have some overlap with bug 693287 but doesn't need such a UI-intense implementation.
(In reply to Erik Rose [:erik][:erikrose] from comment #0)
> Caveat: true, if you start typing the desired username, the corresponding
> password autofills, but I can't always guess what I used for a username,

Note that you can simply press the down arrow to trigger a list of all saved entries, which mitigates this somewhat.
Component: Account Manager → Password Manager
Product: Firefox → Toolkit
QA Contact: account.manager → password.manager
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376668
You need to log in before you can comment on or make changes to this bug.