Developer dashboard doesn't update immediately

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 571405 [details]
screenshot

steps to reproduce:
1. Load https://addons-dev.allizom.org/en-us/developers/addons
2. Add a new version to one of the add-ons
3. Add a new review to one of your add-ons.


observed behavior:
Developer dashboard doesn't update immediately. See screenshot.

Cache-Control is set to no-cache. So I don't see why it isn't updating immediately.


headers:
https://addons-dev.allizom.org/en-US/developers/addons



GET /en-US/developers/addons HTTP/1.1

Host: addons-dev.allizom.org

User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language: en-us,en;q=0.5

Accept-Encoding: gzip, deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Connection: keep-alive

Referer: https://addons-dev.allizom.org/en-US/firefox/addon/turkeyturkey/

Cookie: amo_home_promo_seen=5; AMOv3=g8rca1oid9hh7ta6hv9hdpl5n3; AMOappName=firefox; yes-I-read-the-dev-agreement=; sessionid=c48abbd0b08a0b6554a8ec1d7a0bf5a3; anoncsrf=fe222d03f89914be40994e41cc3f04b7

Pragma: no-cache

Cache-Control: no-cache



HTTP/1.1 200 OK

Server: Apache

Vary: X-Mobile, Accept-Encoding

X-Backend-Server: dev1

Cache-Control: no-cache

Content-Type: text/html; charset=utf-8

Content-Encoding: gzip

Strict-Transport-Security: max-age=2592000

Date: Wed, 02 Nov 2011 19:04:54 GMT

Keep-Alive: timeout=5, max=999

Transfer-Encoding: chunked

x-content-security-policy-report-only: policy-uri /services/csp/policy?build=9c9c

Via: Moz-Cache-pp-zlb01

Connection: Keep-Alive

X-Frame-Options: DENY
I can't reproduce this now. Nothing seems to be cached when I add a review:

http://screencast.com/t/Y78DAeDPO1
(Reporter)

Comment 2

7 years ago
i can still reproduce it. See http://screencast.com/t/62l3o8FfOe
OK, now I can reproduce it with the same steps shown in my previous screencast. Weirdness.
Created attachment 571734 [details]
Add-ons dashboard

Now I can't reproduce it.
Target Milestone: 6.3.0 → 6.3.1
Target Milestone: 6.3.1 → 4.x (triaged)
Assignee: cvan → nobody
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.