Last Comment Bug 699280 - Adapt to the calIChangeLog interface changes (wcap offline support)
: Adapt to the calIChangeLog interface changes (wcap offline support)
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Provider: WCAP (show other bugs)
: unspecified
: All All
: -- normal (vote)
: 1.9
Assigned To: Philipp Kewisch [:Fallen]
:
Mentors:
: 702554 (view as bug list)
Depends on: 380060 756052
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-02 16:33 PDT by Philipp Kewisch [:Fallen]
Modified: 2012-08-02 00:19 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
[checked in] Disable the cache - v1 (784 bytes, patch)
2011-11-02 16:33 PDT, Philipp Kewisch [:Fallen]
no flags Details | Diff | Splinter Review
Fix calIChangeLog Implementation - v1 (5.06 KB, patch)
2012-07-30 06:09 PDT, Philipp Kewisch [:Fallen]
mohit.kanwal: review+
Details | Diff | Splinter Review

Description Philipp Kewisch [:Fallen] 2011-11-02 16:33:21 PDT
Created attachment 571501 [details] [diff] [review]
[checked in] Disable the cache - v1

+++ This bug was initially created as a clone of Bug #697553 +++

Since offline support has landed, both gdata and wcap need some updating. This bug covers wcap support.

First of all, here is a patch that just disables the cache for wcap in total. I know this sucks, but before I break a provider in total I'd rather provide a workaround that successfully migrates users for the time being.

I've tested the upgrade path from cached to no cache and its not noticeable. As soon as the real fix lands, users are then auto-upgraded to using the cache again on restart.
Comment 1 Philipp Kewisch [:Fallen] 2011-11-02 17:09:20 PDT
Comment on attachment 571501 [details] [diff] [review]
[checked in] Disable the cache - v1

I'm going to go this route for the release to make sure I'm not rushing in more big features. Leaving the bug open for the real patch, which should make the next release in 7 weeks.

comm-central changeset cda39712fdae
releases/comm-aurora changeset 01a98a8c26a5
releases/comm-beta changeset c47c0a0a785e
Comment 2 Philipp Kewisch [:Fallen] 2011-11-02 17:59:52 PDT
Hello WCAP Folks,

as mentioned in my previous comment, unfortunately I cannot enable the cache in the next release. I'd be interested to hear how many users are behind your WCAP system and how many of them use Lightning. Is Thunderbird/Lightning managed by your IT department, and if so how is the update policy?

For the release you will have two options:
* Do nothing and the cache will be temporarily disabled.
* Stay with the last release until this bug is fixed

Let me know how this works out for you. Also, if you can convince your mangement to invest developer resources into Lightning this would be marvelous. WCAP currently works, but since its not in my primary focus I can't forsee if any new server patchlevels break the provider and as you've seen before with bug 679669, platform changes that break WCAP might also creep in unannounced.
Comment 3 Stefan Sitter 2011-11-15 03:21:10 PST
*** Bug 702554 has been marked as a duplicate of this bug. ***
Comment 4 Laurent Bauvens 2011-11-17 23:04:53 PST
(In reply to Philipp Kewisch [:Fallen] from comment #2)

Philipp, I sent you a mail about our use of WCAP at your registered mail address in bugzilla, but I wonder whether this address is a technical one or a real personal one.
Comment 5 Philipp Kewisch [:Fallen] 2011-11-18 00:03:24 PST
Laurent, I recevied your email and will reply soon. Thanks for the infos!
Comment 6 letendre123 2012-02-01 10:31:40 PST
At my work, we use this functionality(wcap offline support) since about 1 year because we have network problem. When I'm disconnected, I loose everything.

When do you plan to enable the cache again.

Thanks for your help.
Comment 7 Philipp Kewisch [:Fallen] 2012-02-01 12:52:05 PST
If I get to pick, then I'd rather like to do some changes to the offline interfaces, which might make adaptions to wcap unneeded or very minimal.

Also, thanks for commenting. That reminds me I need to reply to an email!
Comment 8 letendre123 2012-03-07 06:45:19 PST
Hi Philipp,

Still waiting for your work ... ;-)
When do you plan to do it ?
Comment 9 letendre123 2012-05-15 01:35:41 PDT
Hi Philip,

I've got no answer from you ....
Will you enable the cache again for wcap ?

Now I use TB 7.0 and Lightning 1.0b7 to keep the cache functionality.

Thx for your response and have a good day.
Comment 10 Philipp Kewisch [:Fallen] 2012-05-15 02:14:44 PDT
Hi! I have a patch almost working that changes the offline API so that no further methods are needed, which means the cache can be enabled again.

It still needs some testing and I need to find out if a certain case will cause an endless loop or not.

I haven't opened a bug for it yet, but I'll make it block this one so you are in the loop.
Comment 11 Philipp Kewisch [:Fallen] 2012-07-30 06:09:09 PDT
Created attachment 647137 [details] [diff] [review]
Fix calIChangeLog Implementation - v1

This patch fixes the calIChangeLog listener implementation and requires a nightly with bug 756052 applied (tomorrow).

One thing I noticed is that cached WCAP is also showing symptoms of bug 717067, but I think its more minor, the main thing is to get this running.
Comment 12 Mohit Kanwal [:redDragon] 2012-07-30 07:43:43 PDT
Comment on attachment 647137 [details] [diff] [review]
Fix calIChangeLog Implementation - v1

Review of attachment 647137 [details] [diff] [review]:
-----------------------------------------------------------------

Looks alright to me, a couple of style fixes. How to test. Is there a WCAP version available online for testing? and looks like I need to look into bug 717067 pretty soon.

::: calendar/providers/wcap/calWcapCalendarItems.js
@@ +583,4 @@
>              }
>              var items = this_.parseItems(icalRootComp, calICalendar.ITEM_FILTER_ALL_ITEMS,
>                                           0, null, null, true /* bLeaveMutable */);
> +            if (items.length != 1) {

Should we collapse the two cases? one is a Components.Exception the other is just a console error.

@@ +1324,1 @@
>      var this_ = this;

you can use this opportunity to correct the vars into let ;)
Comment 13 Philipp Kewisch [:Fallen] 2012-08-02 00:13:37 PDT
I'd like to leave the wcap provider alone as much as possible. If I start fixing nits on it then I will end with regressions and need start doing large scale changes.
Comment 14 Philipp Kewisch [:Fallen] 2012-08-02 00:19:37 PDT
comm-central changeset 7155880be5bb

Note You need to log in before you can comment on or make changes to this bug.