listbox in "Junk-Filter" account settings not initialized when switching between "Junk-Filter" of two IMAP accounts

RESOLVED DUPLICATE of bug 690277

Status

RESOLVED DUPLICATE of bug 690277
7 years ago
7 years ago

People

(Reporter: tilman, Unassigned)

Tracking

8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 571633 [details]
junk-screenshot.png

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; SBS; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8; .NET4.0C; .NET4.0E; SBS)

Steps to reproduce:

move between the "Junk-Filter" settings between two IMAP accounts in the "account settings" dialog box, because I wanted to see if there are differences.


Actual results:

Each time I clicked on the "Junk-Filter" settings of the other account, the listbox "trust the addresses of these address books" got more entries. This effect happened only when I moved between "Junk-Filter" settings only, not if I clicked on e.g. server settings, and then back to "Junk-Filter". See screenshot that has obvious duplicate entries.


Expected results:

The amount of entries shouldn't grow each time. I believe that the cause is that the "Junk-Filter" listbox isn't emptied/initialized before being filled.
(Reporter)

Comment 1

7 years ago
Happens in TB7 with XP and in the current beta of TB8 on W7.

Comment 2

7 years ago
(In reply to Tilman from comment #0)
See bug 167173.
(Reporter)

Comment 3

7 years ago
(In reply to Hashem Masoud from comment #2)
> (In reply to Tilman from comment #0)
> See bug 167173.
No these aren't related. Mine is about dialogbox handling, while yours is about choosing the correct IMAP commands.

Comment 4

7 years ago
Should be fixed in TB10 (already out) and a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 690277
You need to log in before you can comment on or make changes to this bug.