Order of back/forward history corrupts when viewing images

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P3
normal
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

({regression})

unspecified
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(fennec11+)

Details

(Reporter)

Description

6 years ago
STR:
1. Visit google.com, cnn.com, msnbc.com to get some history
2. Open the awesome bar; head to deviantart.com
3. Tap on one of the images; and tap the thumbnail to enlarge it
4. Tap your back button
5. Tap your forward button

Repeat 4 and 5 a few times

You should be seeing the URI of the image, and deviant art, but each back and forward press displays the earlier sites

--
20111103040334
http://hg.mozilla.org/projects/birch/rev/c09a52af4cd8
Samsung Nexus S (Android 2.3.6)
(Reporter)

Comment 1

6 years ago
When this happens I see in console


E/nsConsoleService( 2036): [JavaScript Error: "browser is null" {file: "chrome://browser/content/browser.js" line: 853}]

Comment 2

6 years ago
is this related to bug 699412?
Priority: -- → P3
Assignee: nobody → lucasr.at.mozilla
(Assignee)

Comment 3

6 years ago
Couldn't reproduce this bug on the Galaxy S. Aaron, can you still reproduce it in latest nightly?
(Reporter)

Comment 4

6 years ago
WFM with recent builds
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.