Signage for Firefox Flicks Preview at MozCamp EU

RESOLVED FIXED

Status

Marketing
Design
--
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Kristin Baird, Assigned: Sean Martell)

Tracking

Details

(Reporter)

Description

7 years ago
Hi,

Sorry for the last minute request but we just confirmed that we are going to have a Firefox Flicks preview/chat at MozCamp EU. Post the sessions and before dinner we are going to have a screening of the 2006 winning videos and get people excited about the upcoming program. We would like a sign to let people know this is happening. 

Size: 3x2' sign 
Messaging: 
Firefox Flicks 
Get excited for the upcoming Firefox Flicks program
Come see the winning videos from the last Firefox Flicks contest 
Hear more about the upcoming Firefox Flicks Program 
Find out how you can help 

Check the agenda for the Firefox Flicks Preview and Video Showing Time

Keep this page bookmarked to learn more: 
www.mozilla.org/firefoxflicks (I am filing a bug for a redirect to Firefox Flicks.com)

(obviously I am not a copywriter)

Graphic: Firefox Flicks logo 

Thanks and let me know if you have questions.
Kristin
(Reporter)

Comment 1

7 years ago
Hey Matej,

Is it possible for you to create a couple of lines of texts for this sign? I'd really appreciate it. 

Thanks a ton!

Comment 2

7 years ago
I started to get a bit carried away with headlines, so I decided to restrain myself from going any further. I also added a thing about popcorn in the copy — not sure if that's true, but it's easy enough to remove. Let me know what you think.


HEADLINE OPTIONS:

Lights. Camera. Awesome.

Firefox Flicks Returns

Firefox Flicks, the Sequel

Firefox Flicks Part II

Firefox Flicks 2: Even Flicker


COPY:

Come see the winning videos from the last Firefox Flicks and learn about our upcoming blockbuster contest, including how you can help behind the scenes. We'll even supply the popcorn!

Check the agenda for showtimes.

More info coming soon at www.mozilla.org/firefoxflicks
(Reporter)

Comment 3

7 years ago
Love it. Thanks a ton! 

Lets go with: 

Lights. Camera. Awesome. 

The rest of the copy is good to go.

I am confirming the popcorn. :)

Comment 4

7 years ago
You missed an easy "Firefox Flicks 2: Electric Boogaloo" joke, but I like the one Kristin picked too.

Comment 5

7 years ago
Yeah, that's a good one, but what I really wanted was:

Firefox Flicks Episode 2: Backstroke of the West
(Reporter)

Comment 6

7 years ago
You guys make me laugh which is a good thing during a long week......

Comment 7

7 years ago
Hey Kristin, when do you need this done by?  Are you planning on just doing the printing yourself / locally in Berlin?  or is this something you're trying to print pre-Berlin ?  Let me know so I can process accordingly.

Comment 8

7 years ago
cc-ing Rhonda.

Sean, could you please send me (or link to, here) the source files for the graphics you created for this campaign?  The logo and the landing page curtains / fonts, etc. 

Thanks!

Comment 9

7 years ago
Sean offered to whip this up real quick since he has all the files!  re-assigning.  Thanks Sean!
Assignee: tshahian → smartell
(Assignee)

Comment 10

7 years ago
Hey all!

Poster preview here: http://cl.ly/3s2R3x2l1m1K3U3T3A3i

If all is good, I'll send a link to the printable artwork.

Thanks!
(Reporter)

Comment 11

7 years ago
Love it. Only comment lets remove the line about popcorn. there is talk that we might do this chat as a session and if that's the case there will be no popcorn. 

Otherwise it is good to go. 

Thanks.

Comment 12

7 years ago
Re. Tara's comment 7, this poster is being printed in Berlin. Dimensions: 508 x 762mm. 

This is a late addition our existing print orders. The planner needs the artwork ASAP, so we can go to print this weekend.

Kristin: I'll send you a cost estimate under separate cover.

Comment 13

7 years ago
Sean, is this something you can update quickly for us today? 

Kristin, just my 2 cents... I thikm it'd be super cool to serve popcorn regardless :)  granted you may run out if there are lots of people in attendance, but it's still a nice touch to the whole thing... so, why not have popcorn regardless of whether it's a session or not?
(Reporter)

Comment 14

7 years ago
I love the idea. Just wasn't sure of the feasibility. Will check with the team.

Comment 15

7 years ago
I hope we can make it work :) pop-corn is easy to make !!  and maybe MAYBE (emphasis on maybe) we could even have customize popcorn paper containers.  with the FF logo.  but I suspect it's too late for that.
(Reporter)

Comment 16

7 years ago
Just chatted with Mary and there is a little bit of a fear that Popcorn is too American so we are going with drinks and snacks. 

Sean, will you please update the poster to read "We'll even supply drinks & snacks" 

Thanks!
(Reporter)

Comment 17

7 years ago
Hey Sean,
Any chance you can make the change I mentioned in comment 16 today and send us the poster ready to be printed? I just got push from the MozCamp team to have to have it finished by COB today.

Thanks!
(Assignee)

Comment 18

7 years ago
Fixed!

Illustrator file here: http://people.mozilla.org/~smartell/poster.ai

Enjoy!
(Reporter)

Comment 19

7 years ago
Looks awesome! Thanks Sean!

Comment 20

7 years ago
What a pretty poster!

Kristin: I'll send this artwork to the printer in Berlin.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Blocks: 701521
You need to log in before you can comment on or make changes to this bug.