Last Comment Bug 699507 - Cleanup the cairo win32 backend
: Cleanup the cairo win32 backend
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla11
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-03 11:52 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2011-11-10 03:14 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
inline check_span_renderer (1.92 KB, patch)
2011-11-08 15:15 PST, Jeff Muizelaar [:jrmuizel]
ajuma.bugzilla: review+
Details | Diff | Splinter Review
remove dead create_span_renderer (4.60 KB, patch)
2011-11-08 15:18 PST, Jeff Muizelaar [:jrmuizel]
ajuma.bugzilla: review+
Details | Diff | Splinter Review
Remove dead fallbacks (13.07 KB, patch)
2011-11-08 15:19 PST, Jeff Muizelaar [:jrmuizel]
ajuma.bugzilla: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2011-11-03 11:52:34 PDT

    
Comment 1 Jeff Muizelaar [:jrmuizel] 2011-11-08 15:15:47 PST
Created attachment 573025 [details] [diff] [review]
inline check_span_renderer

There's no need to call through _cairo_surface_check_span_renderer() because
we can make the decision directly.
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-11-08 15:18:30 PST
Created attachment 573026 [details] [diff] [review]
remove dead create_span_renderer

We create our span renderer ourselves so we don't need to implement create_span_renderer anymore.
Comment 3 Jeff Muizelaar [:jrmuizel] 2011-11-08 15:19:09 PST
Created attachment 573027 [details] [diff] [review]
Remove dead fallbacks

This code was never used.

Note You need to log in before you can comment on or make changes to this bug.