Closed Bug 699533 Opened 10 years ago Closed 9 years ago

save/update password doorhanger does not restore focus

Categories

(Toolkit :: General, defect)

1.9.2 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla15

People

(Reporter: dherman, Assigned: littledodgeviper)

References

()

Details

(Whiteboard: [good first bug][mentor=felipe][lang=js])

Attachments

(1 file, 1 obsolete file)

(I can't tell if this is a dup -- bugs 612248 and 433028 seem related.)

STR:

1. Start Nightly in a new profile.
2. Go to https://phonebook.mozilla.org and fill out your LDAP credentials
3. Wait for the page to load and put the focus in the search field in the middle of the page.
4. Click "Remember password" on the doorhanger; focus is stolen and not restored to the web page.

Dave
I fixed a similar issue with tab-modal prompts over in bug 617507. The same fix should work here -- then the prompt closes, it should  call browser.focus().
Whiteboard: [good first bug]
Whiteboard: [good first bug] → [good first bug][mentor=felipe]
Whiteboard: [good first bug][mentor=felipe] → [good first bug][mentor=felipe][lang=js]
This URL doesn't require a MoCo LDAP account to test it :)

http://seta00.com/mozilla/tests/doorhanger-focus/
User: bug
Password: test
Assignee: nobody → littledodgeviper
Status: NEW → ASSIGNED
This patch fixes all three buttons.
Attachment #625321 - Attachment is obsolete: true
Attachment #625321 - Flags: review?(felipc)
Attachment #626355 - Flags: review?(felipc)
Component: Toolbars → General
OS: Mac OS X → All
Product: Firefox → Toolkit
QA Contact: toolbars → general
Hardware: x86 → All
Version: 3.6 Branch → 1.9.2 Branch
Comment on attachment 626355 [details] [diff] [review]
Version 2 of the first patch.

We should follow-up on this bug or on a separate one to also make the mainAction/secondaryAction cases to work for all doorhangers, and not only the password manager one (i.e., implementing it in PopupNotifications.jsm similarly to the _dismiss implementation)
Attachment #626355 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/76791f5996cc
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
(In reply to Felipe Gomes (:felipe) from comment #5)
> Comment on attachment 626355 [details] [diff] [review]
> Version 2 of the first patch.
> 
> We should follow-up on this bug or on a separate one to also make the
> mainAction/secondaryAction cases to work for all doorhangers, and not only
> the password manager one (i.e., implementing it in PopupNotifications.jsm
> similarly to the _dismiss implementation)

Has this bug been filed?
Duplicate of this bug: 433028
(In reply to Dão Gottwald [:dao] from comment #8)
> > We should follow-up on this bug
> 
> Has this bug been filed?

Has now! I filed bug 824110.

(I'm cleaning up my tabs for the new year.)
You need to log in before you can comment on or make changes to this bug.