files in viewer aren't verified even though they haven't changed

RESOLVED DUPLICATE of bug 698789

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
RESOLVED DUPLICATE of bug 698789
6 years ago
2 years ago

People

(Reporter: myk, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
A number of SDK files in the file viewer look like they have not been verified (i.e. they appear in regular font color, not greyed out) even though they haven't been changed from the versions in the SDK.

For example, the "table calculator" addon <https://addons.mozilla.org/en-US/editors/review/table-calculator?num=15> claims to use SDK version 1.1 <https://addons.mozilla.org/en-US/firefox/files/browse/134716/file/harness-options.json#L1039>, but its addon-kit/lib/windows.js file looks unverified, even though the viewer reports its md5sum as 5b7f1491c71fd18309badd3687a4c700, which is exactly the same as the md5 sum for the file in the SDK source code repository:

mykbook:~ myk$ git clone git@github.com:mozilla/addon-sdk.git
Cloning into 'addon-sdk'...
...
mykbook:addon-sdk myk$ git checkout 1.1
Note: checking out '1.1'.
...
HEAD is now at 4cd0c39... update version for next release
mykbook:addon-sdk myk$ md5 packages/addon-kit/lib/windows.js
MD5 (packages/addon-kit/lib/windows.js) = 5b7f1491c71fd18309badd3687a4c700
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 698789
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.