Session restore saves itself as the session if no changes and loses previous 'actual' session

RESOLVED DUPLICATE of bug 637148

Status

()

RESOLVED DUPLICATE of bug 637148
7 years ago
7 years ago

People

(Reporter: lsblakk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I was trying to test if I could reproduce a bug in a clean profile so I was opening and closing Firefox a lot with my real profile and my clean profile. When I open Firefox with my real profile I get my app tabs and then the landing home page with the session restore button on it.  If I do nothing, quit, and then reopen the restore-able session has now become the landing page and my actual session data is lost. There should be a saving of session state that persists beyond empty open/close of the application so that restore session really means it.
So... let's say it again to make sure I got it.

1. Session with A1, A2, A3, T1, T2, T3 (A = app tab, T = normal tab)
2. Quit
3. Start Firefox,
   A1, A2, A3, about:home
4. Quit
5. Start Firefox
   A1, A2, A3, about:home
6. Restore previous session
   A1, A2, A3, about:home

Is that right?
(Reporter)

Comment 2

7 years ago
Yes, assuming that in point 3 there was a session restore button (that i did not select) which contained the knowledge of T1, T2, T3
Ok. Yea, we don't currently have support for more than 1 previous session.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 637148
You need to log in before you can comment on or make changes to this bug.