Clicking the Learn More link doesn't cause navigation to a Learn More page

VERIFIED FIXED

Status

Firefox Affiliates Graveyard
affiliates.mozilla.org
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: hsivonen, Assigned: mkelly)

Tracking

Details

(URL)

Steps to reproduce:
 1) Load https://affiliates.mozilla.org/en-US/
 2) Click the blue text that says "Learn more »" and shows an underline on hover.

Actual result:
Hovering shows a text bubble but clicking does nothing.

Expected results:
Since the text has the appearance of a link, expected clicking the text to cause navigation to another page.
This is by design, but I agree that it doesn't seem to be the best design.  Thanks for filing :-)
OS: Linux → All
Hardware: x86_64 → All
[:stephend] Maybe using a speech bubble icon next to learn more, instead of the >> will be a better indication of what to expect. Maybe also a slightly different color to set it apart from other 'redirect' links.
Product: Websites → Firefox Affiliates

Comment 3

5 years ago
When I put the cursor over "Learn More" the cursor turns into a pointing finger, indicating it's a link, but I don't get any text bubble and clicking does nothing. I think this is is a bad user experience. Is the text bubble now broken? Why does clicking the link do nothing by design? How can saying "Learn more" with no opportunity to actually learn more be an acceptable experience?
There used to be a speech bubble with text in it. Investigating now.

Comment 5

5 years ago
Thanks Chelsea!
Looks like something broke with the Facebook integration. Assigning to the marvelous mkelly to fix. 

Thanks all!
Assignee: nobody → mkelly
I've had a report of this by email; it's very confusing. mkelly: do you know when you might be able to fix it?

Gerv
Excellent question. Waiting for an update from webdev when they can address it. Getting a lot of complaints about it.
(Assignee)

Comment 9

5 years ago
I should be able to look at this sometime this week.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

5 years ago
Fix is out on prod: https://affiliates.mozilla.org/en-US/

chelsea or gerv: Can you verify?

Comment 12

5 years ago
I just tried it and it worked for me.
(Assignee)

Comment 13

5 years ago
Marking as verified per comment 12, thanks!
Status: RESOLVED → VERIFIED
Thanks so much.
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.