Mozilla Mail crashes on startup user_pref("general.startup.mail", true);

VERIFIED FIXED

Status

MailNews Core
Backend
--
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Peter O'Shea, Assigned: Scott MacGregor)

Tracking

({crash, stackwanted})

Trunk
Sun
Solaris
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Using trunk build 2001022221 for solaris 2.6, Mozilla crashes on startup and
gives the following error message in the console:

### ERROR, cannot create a search session. TypeError:
Components.classes[searchSession] has no properties
JavaScript error: 
chrome://communicator/content/securityUI.js line 29:
Components.classes['@mozilla.org/secure_browser_ui;1'] has no properties

Bus Error

[6]    Exit 138             ~/bin/mozilla/mozilla

Comment 1

17 years ago
securebrowser is unrelated and probably means you aren't building psm
Severity: normal → blocker
Keywords: crash, qawanted, smoketest
Whiteboard: DUPEME
(Reporter)

Comment 2

17 years ago
This is the distribution I used:
http://ftp.mozilla.org/pub/mozilla/nightly/2001-02-22-21-Mtrunk/mozilla-sparc-sun-solaris2.6.tar.gz
- I'm not building Mozilla.
AFAIK, psm isn't included in the distribution.  
(Reporter)

Comment 3

17 years ago
Duh, I should've added that the Solaris build from 24 hours earlier works; I'm
using it now.  Build ID 2001022121.
The search session issue was bug 69949.  And it's probably also unrelated to the
crash...
(Reporter)

Comment 5

17 years ago
As a further point of info, built 2001022521 for Solaris also crashes on startup
at the same place.  This is running on a Sun Ultra2 w/256MB.  All Solaris 2.6
builds up to and including 2001022121 have worked fine on this system.

Comment 6

17 years ago
Reporter try today's build my bet is that will fix the problem since its
reported it was fixed today. bug 69949 that is. Report back either way. Thanks
in advance.
(Reporter)

Comment 7

17 years ago
I tried Solaris 2.6 build 2001022621 and it still crashes.  I've got Mozilla set
up to start the browser and Mailnews on startup, and I see the Mailnews window
appear first for a few seconds before it crashes.  
Could this be related to the fixes for <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=10733">bug 10733</a>?  It
landed about the same time the builds started crashing for me, and it is a
Unix-related checkin.
(Reporter)

Comment 8

17 years ago
Ok, I've got it narrowed down further.  On Solaris builds from 20010223 to the
most current (2001022621), if this pref is enabled, Mozilla crashes on startup
immediately after displaying the Mailnews window:

user_pref("general.startup.mail", true);

Comment 9

17 years ago
Peter, have you tried a new fresh profile?

Can anyone else than Peter confirm this on Solaris?

For now, removing smoketest keyword..
Keywords: smoketest
(Reporter)

Comment 10

17 years ago
Yes, I tried a new profile...with a new profile, it starts ok.  Until I turn on
the user pref: user_pref("general.startup.mail", true);
Then it starts crashing again on startup.  So the obvious workaround is not to
set that flag, and to start MailNews manually after startup.  

Comment 11

17 years ago
reporter could you run mozilla -g and give us the output from bt?
Assignee: asa → mscott
Severity: blocker → critical
Component: Browser-General → Mail Back End
Keywords: qawanted → stackneeded
Product: Browser → MailNews
QA Contact: doronr → esther
Summary: Mozilla crashes on startup → Mozilla Mail crashes on startup user_pref("general.startup.mail", true);
Whiteboard: DUPEME
(Reporter)

Comment 12

17 years ago
Ok, I am now seeing the same crash on my home PC, running build 2001022705 on
WinME. Turning on the pref causes the crash in module JS3250.DLL. With the
pref off, the browser starts fine, and I can then start MailNews with no problem.
I'll try it on Unix with the -g later this morning.

Comment 13

17 years ago
Confirming based on above comments..

JS3250 sounds like a Javascript thing.. cc'ing brendan
Status: UNCONFIRMED → NEW
Ever confirmed: true
I like that stackneeded keyword, I didn't know about that one.  Without a stack
backtrace, it's fruitless to speculate.  Crashing in js3250.dll could mean a bad
pointer is being passed to JS (as happens, e.g., in bug 31847), due to a bug in
another module.

/be
(Reporter)

Comment 15

17 years ago
Ok, being a gdb debugger novice it took a few tries.  After setting the
offending user pref, this is how I invoked it:
run-mozilla.sh -g mozilla-bin

It complained a bunch about not finding debugging symbols.  I'm attaching a text
file containing the debugging session once I gave the gdb "run" command,
including the bt (backtrace?) after execution halted.  Hope this helps.
(Reporter)

Comment 16

17 years ago
Created attachment 26414 [details]
Debugger output during crash condition.
We need symbols for all those libraries on the ?? () lines -- try typing 'sha
caps', 'sha gkcontent', and 'sha jsdom' to get the top three libraries' symbol
tables loaded.  This still looks like a dup or close cousin of 31847 to me. 
Cc'ing mstoltz in case he's seen similar from caps code.

/be
(Reporter)

Comment 18

17 years ago
Created attachment 26528 [details]
debugger output using suggested sha commands
This looks like another symptom of the same bad cause reported in bug 31847,
IOW, a dup.  joki, any hope of a fix?

/be
(Reporter)

Comment 20

17 years ago
FWIW, recent builds (I'm using 2001040910 now) don't show the crash behavior
when activating the pref.  Don't know when it started working, since I haven't
had the pref turned on since a few days after I reported the bug.
(Assignee)

Comment 21

17 years ago
great. I'm going to mark this as fixed then. thanks everyone.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
Close it since someone who uses solaris verified it already.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.