Last Comment Bug 699741 - Do not prevent sending levelchange event if the change is less than 0.01
: Do not prevent sending levelchange event if the change is less than 0.01
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks: 678694
  Show dependency treegraph
 
Reported: 2011-11-04 03:12 PDT by Mounir Lamouri (:mounir)
Modified: 2011-11-15 14:45 PST (History)
4 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.05 KB, patch)
2011-11-04 04:05 PDT, Mounir Lamouri (:mounir)
cjones.bugs: review+
asa: approval‑mozilla‑aurora-
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2011-11-04 03:12:07 PDT
The specs required that but do not anymore. In addition, the backend should be smart enough to not send us too many events. If not, we will be able to tweak that later. In the meantime, let's have a simple implementation.
Comment 1 Mounir Lamouri (:mounir) 2011-11-04 04:05:21 PDT
Created attachment 571926 [details] [diff] [review]
Patch v1

The Android backend is still going to check if there is a change which the upower backend does not because the DOM code already checks that before sending the events. The idea is to prevent going through JNI then from the parent process to the child process to finally not send the event.
Comment 2 Mounir Lamouri (:mounir) 2011-11-09 06:23:25 PST
Comment on attachment 571926 [details] [diff] [review]
Patch v1

This has just landed in mozilla-inbound. Requesting aurora approval for API completeness in Firefox 10. It would be better to ship Firefox 10 with the entire API if we say it is present. The risk is very low given that there is no use of the API for the moment.
Comment 3 Marco Bonardo [::mak] 2011-11-10 03:09:19 PST
https://hg.mozilla.org/mozilla-central/rev/14e180318688
Comment 4 Asa Dotzler [:asa] 2011-11-15 14:45:04 PST
Comment on attachment 571926 [details] [diff] [review]
Patch v1

It looks like this feature wasn't ready for 10. Please re-nominate if you have a good justification for trying to get this into 10 rather than just waiting for 11.

Note You need to log in before you can comment on or make changes to this bug.