Last Comment Bug 699745 - Don't use \u escapes in htmlparser.properties
: Don't use \u escapes in htmlparser.properties
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 03:29 PDT by Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
Modified: 2011-11-04 11:35 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Perform the unescaping (2.46 KB, patch)
2011-11-04 03:33 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
no flags Details | Diff | Splinter Review
Perform the unescaping for real (15.80 KB, patch)
2011-11-04 06:10 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
l10n: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-04 03:29:57 PDT
Turns out that, unlike real Java .properties files, Gecko .properties files are UTF-8. Furthermore, localizers didn't like the escapes.
Comment 1 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-04 03:33:15 PDT
Created attachment 571920 [details] [diff] [review]
Perform the unescaping
Comment 2 Axel Hecht [:Pike] 2011-11-04 06:04:20 PDT
Comment on attachment 571920 [details] [diff] [review]
Perform the unescaping

Review of attachment 571920 [details] [diff] [review]:
-----------------------------------------------------------------

This is the wrong patch for this bug, canceling the review.
Comment 3 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-04 06:10:50 PDT
Created attachment 571943 [details] [diff] [review]
Perform the unescaping for real

Oops.
Comment 4 Axel Hecht [:Pike] 2011-11-04 06:21:57 PDT
Comment on attachment 571943 [details] [diff] [review]
Perform the unescaping for real

Review of attachment 571943 [details] [diff] [review]:
-----------------------------------------------------------------

looks much better this way, isn't it nice that we didn't have to do java back then.

Sob, now I gotta look at java all day :-(
Comment 5 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-04 06:38:52 PDT
Thanks.

https://hg.mozilla.org/integration/mozilla-inbound/rev/6beb79fc1c1a
Comment 6 Matt Brubeck (:mbrubeck) 2011-11-04 11:35:27 PDT
https://hg.mozilla.org/mozilla-central/rev/6beb79fc1c1a

Note You need to log in before you can comment on or make changes to this bug.