Last Comment Bug 699799 - Don't AddRef/Release every uncollectable document before cycle collection
: Don't AddRef/Release every uncollectable document before cycle collection
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Peter Van der Beken [:peterv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 07:52 PDT by Peter Van der Beken [:peterv]
Modified: 2011-11-07 17:25 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (887 bytes, patch)
2011-11-04 07:52 PDT, Peter Van der Beken [:peterv]
jst: review+
Details | Diff | Splinter Review

Description Peter Van der Beken [:peterv] 2011-11-04 07:52:01 PDT
Created attachment 571971 [details] [diff] [review]
v1

The Release adds the document to the cycle collector as a suspect, even though we know it's not collectable (that's the whole point of the code in nsCCUncollectableMarker).
Comment 1 Andrew McCreight [:mccr8] 2011-11-04 09:41:23 PDT
Is this just going to avoid adding the document itself, due to the nsCCUncollectableMarker optimization, or will it pull in some successors of the document too?  One thing I want to look into is what exactly the large DOM-y globs that show up in the cycle collector graph actually are.  One theory I've had is that we aren't pruning out all visible documents that we should.
Comment 2 Peter Van der Beken [:peterv] 2011-11-07 09:21:59 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/1aab8b1485dd
Comment 3 Peter Van der Beken [:peterv] 2011-11-07 09:22:29 PST
(In reply to Andrew McCreight [:mccr8] from comment #1)
> Is this just going to avoid adding the document itself, due to the
> nsCCUncollectableMarker optimization

I think so, yes.
Comment 4 Ed Morley [:emorley] 2011-11-07 17:25:34 PST
https://hg.mozilla.org/mozilla-central/rev/1aab8b1485dd

Note You need to log in before you can comment on or make changes to this bug.