Thunderbird randomly adds space characters when composing Chinese or Japanese HTML messages

RESOLVED DUPLICATE of bug 653342

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 653342
7 years ago
7 years ago

People

(Reporter: dreamon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 572044 [details]
ff-asian-font-substitution.JPG

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928224508

Steps to reproduce:

Thunderbird apparently randomly adds spaces to Chinese and Japanese emails when composing HTML messages. This is rather annoying, as it makes Thunderbird completely unusable for composing rich-text emails in Chinese or Japanese.

Steps to reproduce:
1. Create a new message in HTML format
2. Paste some Chinese or Japanese text into the editor window (sample text attached)
3. Press send
4. Check the email in Thunderbird's Sent folder and in the receiving account's inbox


Actual results:

What happens instead: the email gets reformatted before it is sent out; a space is inserted every couple of characters (see attached screenshot)


Expected results:

Expected result: the email that gets sent off should look the same as it did in your editor window
(Reporter)

Comment 1

7 years ago
Created attachment 572045 [details]
Chinese sample text
(Reporter)

Comment 2

7 years ago
Created attachment 572046 [details]
Japanese sample text
(Reporter)

Comment 3

7 years ago
Created attachment 572049 [details]
Screenshot of email after it has been received

Sorry I uploaded the wrong screenshot here at first
Attachment #572044 - Attachment is obsolete: true
dup of bug 653342(or dup of the bug)?
(Reporter)

Comment 5

7 years ago
Thanks for pointing me to the correct bug report, WADA. I will mark this as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653342
You need to log in before you can comment on or make changes to this bug.