Link errors on Firefox Central page and correct Title menu items to not link but only drop down

RESOLVED FIXED in 4.5

Status

www.mozilla.org
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Terry R., Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
At the top of the page, clicking on Releases is directed to the mobile page:  https://www.mozilla.org/en-US/mobile/

Releases > Download is directed to the channel page:   https://www.mozilla.org/en-US/firefox/channel/ 

Releases > Firefox Beta is directed to the releases page: https://www.mozilla.org/en-US/firefox/new/

Once the above is corrected, if "Releases" and "Mobile" are going to remain clickable, then "Download" is redundant on both of them.
Same for the footer links too
Target Milestone: --- → 4.5
Thanks for the report. This was caused by a conflict during the last rollout that wasn't fixed correctly.

Fixed in r97399
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
James,

Were the redundant "Download" links removed?  Also, when Desktop is clicked on, it directs to Features, Add-ons is directed to Desktop Add-ons, Support is directed to Desktop Support, and About is directed to About Firefox.  All of those have redundant menu links.
No, they weren't. That's more of a decision with engagement. If you want to discuss that, can you file a new bug (or change the summary of this one) and assign to lforrest or cbrodigan?
qa-verified-trunk http://www-dev.allizom.org/en-US/firefox/fx/
Raymond, the problem actually only existed on the live site because it a bug was deployed incorrectly, so you can go ahead and verify it on the live site.
verified fixed http://www.mozilla.org/en-US/firefox/fx/
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

6 years ago
Re: http://www.mozilla.org/en-US/firefox/fx/
Still seeing:
Headers and footers, clicking on "Releases" is directed to the channel page:  
https://www.mozilla.org/en-US/firefox/channel/ 

Releases > Download is directed to the channel page:   https://www.mozilla.org/en-US/firefox/channel/ 

Releases > Firefox Beta is directed to the releases page: https://www.mozilla.org/en-US/firefox/new/

Also, I've found the same issue here:  http://www.mozilla.org/firefox/features/
Should be part of this bug, correct? 

**Again clicking "Releases" and Releases->Download is redundant, as is "Mobile" and Mobile->Download.  In most OS UI's, clicking a Title menu does not invoke an action.  Hovering should cause the drop down menu, but the Title menu should not be clickable.  

Firefox also breaks UI tradition making Firefox button, Options clickable, when it has an arrow denoting a sub menu.  This has caused confusion in supporting users, but that's another issue...
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

6 years ago
Summary: Link errors on Firefox Central page → Link errors on Firefox Central page and correct Title menu items to not link but only drop down
Thanks for the detailed report, Terry. You are correct that the beta link is broken. I fixed this in r97722.

As for the other issues, I can't answer them. Laura or Chrissie, should the "Releases > Download" really go to the channel page? It sounds like it should go to a page to download the latest released version.

These bugs are in the nav so that are on every page.
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
The menu items have been revised. Mark as fixed per comment 9.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.