Last Comment Bug 699937 - content overpan gets stuck over panning
: content overpan gets stuck over panning
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 700008 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 15:04 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-01-09 11:02 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
screen shot (85.81 KB, image/png)
2011-11-04 15:04 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details
(1/2) Some cleanup (5.24 KB, patch)
2011-11-21 08:30 PST, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review+
Details | Diff | Splinter Review
(2/2) Fix for stuck-in-overpanning (2.02 KB, patch)
2011-11-21 08:31 PST, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review-
Details | Diff | Splinter Review
(2/2) Fix for stuck-in-overpanning (v2) (2.92 KB, patch)
2011-11-21 10:28 PST, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-11-04 15:04:11 PDT
Created attachment 572091 [details]
screen shot

with pcwalton's patches applied I tried panning and wound up with the content stuck at the bottom of the page
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-11-04 21:06:46 PDT
*** Bug 700008 has been marked as a duplicate of this bug. ***
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-21 07:59:55 PST
I've seen this happen as well, it happens if you fling the page into overscroll and then do a tap. The tap for some reason cancels the page snapping back, and so it gets stuck in overscroll. Happens on current birch tip as well.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-21 08:30:53 PST
Created attachment 575874 [details] [diff] [review]
(1/2) Some cleanup
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-21 08:31:30 PST
Created attachment 575875 [details] [diff] [review]
(2/2) Fix for stuck-in-overpanning
Comment 5 Chris Lord [:cwiiis] 2011-11-21 09:33:32 PST
Comment on attachment 575874 [details] [diff] [review]
(1/2) Some cleanup

Review of attachment 575874 [details] [diff] [review]:
-----------------------------------------------------------------

Fine of course, this variable is unused.
Comment 6 Chris Lord [:cwiiis] 2011-11-21 09:36:36 PST
Comment on attachment 575875 [details] [diff] [review]
(2/2) Fix for stuck-in-overpanning

Review of attachment 575875 [details] [diff] [review]:
-----------------------------------------------------------------

I did the same thing in my patches and I think this makes the same mistake - if you call fling like this, you need to make sure to cancel the fling timer on touch-down, otherwise you end up offsetting the velocity twice as the fling handler is still running when you start panning.
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-21 10:28:47 PST
Created attachment 575905 [details] [diff] [review]
(2/2) Fix for stuck-in-overpanning (v2)

Good catch, thanks. I've moved the code to cancel the timer up to the beginning of onTouchStart.
Comment 8 Chris Lord [:cwiiis] 2011-11-21 12:22:27 PST
Comment on attachment 575905 [details] [diff] [review]
(2/2) Fix for stuck-in-overpanning (v2)

Review of attachment 575905 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good - I assume it's tested to work, so r+ from me!
Comment 10 Catalin Suciu [:csuciu] 2011-11-23 23:51:26 PST
I cannot reproduce this issue on the latest fennec native build.
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111123 Firefox/11.0a1 Fennec/11.0a1
Samsung GalaxyS, Android 2.2

Note You need to log in before you can comment on or make changes to this bug.