If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SSL/IMAP with cert-auth doesn't work on todays builds

VERIFIED FIXED

Status

MailNews Core
Networking: IMAP
--
blocker
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: dmose, Assigned: dougt)

Tracking

({smoketest})

Trunk
x86
Linux
smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
SSL/IMAP with cert auth on today's build doesn't work.  It eventually falls back
to trying password auth, which that server does not allow, meaning that reading
mail with today's build is impossible.  Build 2001022308.
(Reporter)

Comment 1

17 years ago
Interestingly, a few moments ago, the invocation of mozilla that i used to
reproduce this bug crashed with the following stack trace:

#0  0x4091a203 in NSGetModule ()
   from /usr/local/mozilla/components/libpsmglue.so
#1  0x40918824 in NSGetModule ()
   from /usr/local/mozilla/components/libpsmglue.so
#2  0x4093844b in CMT_ServicePasswordRequest ()
   from /usr/local/mozilla/libcmt.so
#3  0x40938384 in CMT_DispatchEvent () from /usr/local/mozilla/libcmt.so
#4  0x40937f6c in CMT_ProcessEvent () from /usr/local/mozilla/libcmt.so
#5  0x40937fb9 in CMT_EventLoop () from /usr/local/mozilla/libcmt.so
#6  0x409184d0 in NSGetModule ()
   from /usr/local/mozilla/components/libpsmglue.so
#7  0x401a64ae in PR_Select () from /usr/local/mozilla/libnspr4.so
#8  0x401beb85 in pthread_start_thread (arg=0xbdbffe40) at manager.c:241
#9  0x401bf54c in pthread_start_thread_event (arg=0xbdbffe40) at manager.c:264
(gdb)
(Reporter)

Updated

17 years ago
Keywords: smoketest

Comment 2

17 years ago
Initial debugging finds that the nsPSMSocketInfo has a nsnull channel and that
causes some havoc.  Will probably need some help from bryner on this one.

Comment 3

17 years ago
doug, there's rumbling that this might have to do with nsIChannel changes... are 
you around to take a look?

Comment 4

17 years ago
cc'ing myself

Comment 5

17 years ago
Do the smoketests include checking for this?  If so, why wasn't this caught
during the carpool yesterday?  ... just wondering.
(Assignee)

Comment 6

17 years ago
i will look at this bug.
Assignee: mscott → dougt
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 7

17 years ago
Not sure if the smoketests look for this directly or not.  However, I think this
was masked in yesterday's build by another, more serious problem with PSM that
was fixed by some combination of dbaron/cls/javi.
(Assignee)

Comment 8

17 years ago
Okay, this turns out to be my bug in a bad way.  It is really a simple problem.  
The nsImapMockChannel has an attribute called securityInfo.  It is a 
nsISupports.  It useto cache the value in a member |mSecurityInfo|.  

After my merge to the trunk, this caching was removed.  The fix is to revert 
the setter and getter to the prior functionality.

I will attach a patch that will do this.

Now, here is how I tested it.

1.  Launched PSM Security Advisor.  Made sure that my email cert was installed 
and that PSM would not automatically select my certification (I want to see the 
dialog).
2.  Change my IMAP mail server (nsmail-2.mcom.com) connection to be ssl.
3.  Exited, relaunched mail.
4.  Pressed 'Get Messages' button.
5.  Verified that the Client Auth Cert dialog appeared.

(Assignee)

Comment 9

17 years ago
Created attachment 26108 [details] [diff] [review]
Fix to mock imap channel
(Assignee)

Comment 10

17 years ago
got a r=darin.  I am checking in so that this can be in the morning builds.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Using DougT's test above on mac winme and linux with builds 03-05-01 this is
fixed.  I verified that the Client Auth Cert appeared.   If this requires
additional steps please reopen and include them.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.