Last Comment Bug 700195 - "Assertion failure: !cx->isExceptionPending()" with isPrivilegeEnabled throwing
: "Assertion failure: !cx->isExceptionPending()" with isPrivilegeEnabled throwing
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla11
Assigned To: Steve Fink [:sfink] [:s:]
:
Mentors:
Depends on:
Blocks: 326633
  Show dependency treegraph
 
Reported: 2011-11-06 17:34 PST by Jesse Ruderman
Modified: 2011-11-21 09:07 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (asserts fatally when loaded) (94 bytes, text/html)
2011-11-06 17:34 PST, Jesse Ruderman
no flags Details
stack trace (6.26 KB, text/plain)
2011-11-06 17:34 PST, Jesse Ruderman
no flags Details
return false on error (922 bytes, patch)
2011-11-17 18:03 PST, Steve Fink [:sfink] [:s:]
bobbyholley: review+
Details | Diff | Splinter Review

Description Jesse Ruderman 2011-11-06 17:34:23 PST
Created attachment 572363 [details]
testcase (asserts fatally when loaded)

Assertion failure: !cx->isExceptionPending(), at js/src/jscntxtinlines.h:300

(Should throw an exception along the lines of "not enough arguments".)
Comment 1 Jesse Ruderman 2011-11-06 17:34:50 PST
Created attachment 572364 [details]
stack trace
Comment 2 Steve Fink [:sfink] [:s:] 2011-11-17 18:03:33 PST
Created attachment 575353 [details] [diff] [review]
return false on error
Comment 3 Bobby Holley (:bholley) (busy with Stylo) 2011-11-17 21:22:31 PST
Comment on attachment 575353 [details] [diff] [review]
return false on error

I'm not a peer in this code, but this seems like a reasonable change. r=bholley.

NB: This entire API is going away soon.
Comment 4 Steve Fink [:sfink] [:s:] 2011-11-18 10:54:22 PST
(In reply to Bobby Holley (:bholley) from comment #3)
> I'm not a peer in this code, but this seems like a reasonable change.
> r=bholley.

Whoops, sorry. I didn't really pay attention to where this fix ended up.

> NB: This entire API is going away soon.

For that reason, and because it's such a simple fix, and because I'm a bad person, I think I'll land it anyway.
Comment 6 Matt Brubeck (:mbrubeck) 2011-11-21 09:07:07 PST
https://hg.mozilla.org/mozilla-central/rev/d048ad9ebe24

Note You need to log in before you can comment on or make changes to this bug.