Unable to get mod_perl to work with Class:Load version 0.12

RESOLVED WORKSFORME

Status

()

Bugzilla
Installation & Upgrading
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Albert Ting, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
About a month ago mod_perl was working fine.  But then I rebuilt the "lib" directory via install-module.pl and it installed Class::Load version 0.12.  This newer version prevented me from starting apache with mod_perl.  I didn't get any error message nor warning message, httpd just wouldn't start.

It appears Date::Time uses Class::Load.

I had to force Class::Load back to version 0.10 in order for mod_perl to work again.
(Reporter)

Updated

6 years ago
OS: Windows 7 → Linux

Comment 1

6 years ago
Does mod_perl work with Class::Load 0.11? Because 0.12 is really a minimum requirement change only compared to 0.11.
(Reporter)

Comment 2

6 years ago
It also fails with v0.11.

Comment 3

6 years ago
Did you report this bug to CPAN? It's much easier for us to blacklist broken versions if the latest one is working.
(Reporter)

Comment 4

6 years ago
Yes, I just sent the report to CPAN.  Looks like DateTime-TimeZone-1.41 requires it

Comment 5

6 years ago
It would be good to have somebody try to report this. If it causes new mod_perl installs to fail and there's something we can do, it's a blocker.
Keywords: qawanted
Hardware: x86 → All

Updated

6 years ago
(Reporter)

Comment 6

6 years ago
I narrowed it down.  The problem only occurs if I statically compile mod_perl (httpd 2.2.21, mod_perl 2.0.5).  If I dynamically load mod_perl, I am able to use the latest Class::Load version.

Have also posted my comment to the RT ticket
(Reporter)

Comment 7

6 years ago
Latest feedback from their RT system:

  This is a side effect of Params::Classify not being thread-safe. This is addressed in   
  Class::Load 0.17, which requires a new Module::Require, which no longer uses 
  Params::Classify (see also RT#72988).

Comment 8

6 years ago
Class::Load 0.17 is now available on CPAN, so it looks like this is no longer an issue. install-module.pl will automatically find it if it has to install it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.