Restore previous session button does not work

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Jörn Hees, Unassigned)

Tracking

7 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-07-25])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

I had some tabs open in FF 7.0.1 on Mac OS X, restarted computer. Reopened Firefox, about:home showed up with the "Restore previous session" button. Clicked on it, nothing happens. I debugged this further, sessionstore.js and .bak seemed ok, but due to too often restarting FF (also in safe-mode) they didn't contain my original session anymore :(
I could reproduce the problem by opening any two pages in tabs, quitting, and starting FF, button on about:home did not work.

More interestingly the History / Restore previous session menu item works!

Uneducated guess: Somehow the eventhandler for the button might have been disconnected.


Actual results:

Nothing happened


Expected results:

Previous session should've been restored.

Comment 1

6 years ago
Likely Bug 682944

Comment 2

6 years ago
I am experiencing the same problem.  I had the problem with FF 7.01 and still have it now that I have upgraded to FF 8.0.

Comment 3

5 years ago
(In reply to Alice0775 White from comment #1)
> Likely Bug 682944

This has since been fixed. can you still reproduce using a current version?
Flags: needinfo?(mozilla)
Whiteboard: [closeme 2013-07-25]
(Reporter)

Comment 4

5 years ago
seems long fixed...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mozilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.