Last Comment Bug 700311 - trunk crashes in msvcr80.dll@0x14500 or msvcr90.dll@0x1e8e1 coming from JSD code
: trunk crashes in msvcr80.dll@0x14500 or msvcr90.dll@0x1e8e1 coming from JSD code
Status: RESOLVED DUPLICATE of bug 700302
[firebug-p1][STR in comment 1]
: crash, reproducible, stackwanted
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- critical (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
: 701001 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-07 07:47 PST by Robert Kaiser
Modified: 2011-11-28 14:00 PST (History)
11 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
-


Attachments

Description Robert Kaiser 2011-11-07 07:47:41 PST
This bug was filed from the Socorro interface and is 
report bp-212a8fe2-ad64-4be0-aa64-1200e2111107 .
============================================================= 

There's different stacks leading up to those, but the top frames on the msvcr80.dll (32bit) ones are always:
0 	msvcr80.dll 	msvcr80.dll@0x14500 	
1 	xul.dll 	jsds_ExecutionHookProc 	js/jsd/jsd_xpc.cpp:684
2 	xul.dll 	jsd_CallExecutionHook 	js/jsd/jsd_hook.c:177
3 	xul.dll 	jsd_ThrowHandler 	js/jsd/jsd_hook.c:149
4 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:5950

More such reports are to be found at https://crash-stats.mozilla.com/report/list?signature=msvcr80.dll%400x14500

The msvcr90.dll (64bit) ones, e.g. bp-9cdfdfbe-0bb4-4bbb-9883-f533f2111107 have the following top frames:
0 	msvcr90.dll 	msvcr90.dll@0x1e8e1 	
1 	xul.dll 	jsds_FilterHook 	js/jsd/jsd_xpc.cpp:381
2 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6220
3 	nspr4.dll 	MD_CURRENT_THREAD 	nsprpub/pr/src/md/windows/w95thred.c:308
4 	xul.dll 	jsdValue::jsdValue 	js/jsd/jsd_xpc.cpp:2157
5 	nspr4.dll 	PR_Unlock 	nsprpub/pr/src/threads/combined/prulock.c:347
6 	xul.dll 	jsdValue::FromPtr 	js/jsd/jsd_xpc.cpp:2147
7 	xul.dll 	jsds_ExecutionHookProc 	js/jsd/jsd_xpc.cpp:684
8 	xul.dll 	jsd_NewThreadState 	js/jsd/jsd_stak.c:169
9 	xul.dll 	xul.dll@0x8d6d63 	
10 	xul.dll 	xul.dll@0x8d6d63 	
11 	xul.dll 	xul.dll@0x8d6d63 	
12 	xul.dll 	jsd_CallExecutionHook 	js/jsd/jsd_hook.c:177
13 	xul.dll 	jsd_ThrowHandler 	js/jsd/jsd_hook.c:149
14 	xul.dll 	xul.dll@0x8d6d63 	
15 	xul.dll 	js::Interpret 	js/src/jsinterp.cpp:5950

More such reports can be found at https://crash-stats.mozilla.com/report/list?signature=msvcr90.dll%400x1e8e1

Those are new crashes appearing since the 2011-11-05 Nightly build and as JSD is involved, it looks like those people have Firebug installed (also from inspecting the reports).
Given the regression range and JSD involvement, bug 700302 might be related.
Comment 1 Jan Honza Odvarko [:Honza] 2011-11-07 08:03:44 PST
My STR:

1) Install Firebug from here: 
http://getfirebug.com/releases/firebug/1.9/firebug-1.9.0a5.xpi
2) Restart Firefox, load www.google.com, open Firebug and enable the Script panel
(I also set www.google.com as the home page)
3) Restart, Firebug should be enabled by default -> Crash
(You might need to restart several times to repro the crash)

Sometimes the crash happens when shutdowning Firefox, sometimes when it's starting.

Honza
Comment 2 Jan Honza Odvarko [:Honza] 2011-11-08 00:20:35 PST
Steve, do you have an idea what could be wrong here?
Honza
Comment 3 Thomas Ahlblom 2011-11-09 13:18:45 PST
*** Bug 701001 has been marked as a duplicate of this bug. ***
Comment 4 B.J. Herbison 2011-11-10 13:44:57 PST
I'm getting this crash on every exit with my existing Nightly profile on the 10 November build -- start, do nothing, exit, crash.

Looking back I saw this crash twice on the 8 November build, but today it's happening on every exit (and I didn't see it on 9 November).

My app tab also vanished. It was present after I updated, but every time I've restarted after that initial start there was no app tab. That is probably bug 701481 and I have no reason to believe the two situations are related.
Comment 5 timeless 2011-11-13 16:00:34 PST
Could someone please use the symbol server to get a proper stack trace?
Comment 6 Scoobidiver (away) 2011-11-15 00:56:20 PST
It's #3 top crasher in 10.0a2 and #4 in 11.0a1.
Comment 7 Steve Fink [:sfink] [:s:] 2011-11-15 15:02:07 PST
The msvcr90.dll ones from comment 0 are almost certainly bug 700302 and should go away with that fix.

The msvcr80.dll ones probably are too, though I don't know why it's not showing the jsds_FilterHook frame. Then again, the msvcr90.dll stacks seem a bit mangled too, since js/jsd/jsd_xpc.cpp:684 does not call jsdValue::FromPtr.
Comment 8 Steve Fink [:sfink] [:s:] 2011-11-17 15:05:44 PST

*** This bug has been marked as a duplicate of bug 700302 ***

Note You need to log in before you can comment on or make changes to this bug.