Closed Bug 700323 Opened 8 years ago Closed 8 years ago

Not possible to change # of balls (select option list)

Categories

(Firefox for Android :: General, defect, P2)

x86
Linux
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox11 --- verified
fennec 11+ ---

People

(Reporter: romaxa, Assigned: wesj)

References

()

Details

Attachments

(1 file)

Attempt to change amount of balls on http://bubblemark.com/dhtml.htm does not trigger actual change.
seems fire onchange is missing
The old code to do this is here:

http://mxr.mozilla.org/mozilla-central/source/mobile/chrome/content/forms.js#958

Just need to port it to the new stuff.
Assignee: nobody → wjohnston
Priority: -- → P2
Attached patch Patch v1Splinter Review
Patch. I left in the setTimeout from the previous code. Not sure if we sill need it or not, and blame isn't helping. Vivien said it had something to do with a site showing an alert when it received onChange. Doesn't seem like it will hurt to keep it in, but it would be nice to have some comment as to why...
Attachment #572552 - Flags: review?(mark.finkle)
Comment on attachment 572552 [details] [diff] [review]
Patch v1

Sounds fine to keep the setTimeout. Might be an issue with firing an event from an event too.
Attachment #572552 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 700391
http://hg.mozilla.org/projects/birch/rev/cd32f4fce7ef
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
20111108040346
http://hg.mozilla.org/projects/birch/rev/df8c264a45d9
-- Samsung Nexus S (Android 2.3.6)
Status: RESOLVED → VERIFIED
These patches were backed while investigating Talos failures.  Now that tests are green again, we will need to reland.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
backout was backed out https://hg.mozilla.org/projects/birch/rev/6f925b45a547
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Where are the tests for this?
tracking-fennec: --- → 11+
Verified fixed on Native Nightly 13.0a1 (2012-02-15)
                  Native Beta 11.0 (20120215185359)
Device: Samsung Galaxy SII (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.