The default bug view has changed. See this FAQ.

Highlighter close button has a bogus hover state on Windows

RESOLVED FIXED in Firefox 10

Status

()

Firefox
Developer Tools
--
trivial
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: dao, Assigned: rc)

Tracking

({verified-beta})

Trunk
Firefox 11
x86
Windows XP
verified-beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox10+ verified)

Details

(Whiteboard: [qa+][qa!:10])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 572494 [details] [diff] [review]
patch
Attachment #572494 - Flags: review?
(Reporter)

Updated

6 years ago
Attachment #572494 - Flags: review? → review?(rcampbell)
Shouldn't this be for Linux as well? The close button also has a weird hover state on my Ubuntu system.
(Reporter)

Comment 2

6 years ago
Linux uses,instead of custom images, a stock icon, which is supposed to be used with the native toolbar button style.
(In reply to Dão Gottwald [:dao] from comment #2)
> Linux uses,instead of custom images, a stock icon, which is supposed to be
> used with the native toolbar button style.

True. I see the native button graphics and icon when I hover - which looks broken in the current toolbar design.
(Assignee)

Comment 4

6 years ago
I saw this yesterday as well. Checking...
(Assignee)

Comment 5

6 years ago
Comment on attachment 572494 [details] [diff] [review]
patch

Thanks for the patch!
Attachment #572494 - Flags: review?(rcampbell) → review+
(Assignee)

Comment 6

6 years ago
marking this as tracking firefox 10.

This is a styling fix for a single platform. Risk is negligible. It improves the appearance of the Highlighter's toolbar on Windows.
tracking-firefox10: --- → ?
(Assignee)

Comment 7

6 years ago
Comment on attachment 572494 [details] [diff] [review]
patch

asking for approval on aurora 10.
Attachment #572494 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

6 years ago
Whiteboard: [land-in-fx-team]

Comment 8

6 years ago
Comment on attachment 572494 [details] [diff] [review]
patch

[Triage Comment]
Given this is just a styling change, approving for aurora.
Attachment #572494 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 9

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/8e42e063903b
Whiteboard: [land-in-fx-team]
Target Milestone: --- → Firefox 11
Backed out of inbound for Mochitest failures on Windows:

https://tbpl.mozilla.org/php/getParsedLog.php?id=7314472&tree=Mozilla-Inbound
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box width matches dimensions of element (no zoom) - Got 0, expected 22
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box width matches width of element (2x zoom) - Got 937, expected 44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box height matches width of element (2x zoom) - Got 76, expected 44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_iframeTest.js | selection matches div2 node - Got [object HTMLDivElement], expected [object HTMLDivElement]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_iframeTest.js | highlighter matches selection - Got [object HTMLDivElement], expected [object HTMLDivElement] 
}

https://hg.mozilla.org/integration/mozilla-inbound/rev/f7ea68d2d546
Target Milestone: Firefox 11 → ---
(Reporter)

Comment 11

6 years ago
What the hell... what are these tests doing?
(Reporter)

Updated

6 years ago
Assignee: dao → nobody
Status: ASSIGNED → NEW
(Reporter)

Updated

6 years ago
Attachment #572494 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 12

5 years ago
Did the patch apply cleanly when it went in? I had to do some tweaking to get it to apply on my machine for whatever reason. There's no way that should've affected those tests, but I will try to verify and renom for aurora.
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Assignee: nobody → rcampbell
(Reporter)

Comment 13

5 years ago
(In reply to Rob Campbell [:rc] (robcee) from comment #12)
> Did the patch apply cleanly when it went in?

Yep. Bug 701212 landed in the meantime.

Comment 14

5 years ago
I can't reproduce (central + this patch rebased).
I'll see how it goes with the try-server.

Comment 15

5 years ago
Created attachment 574564 [details] [diff] [review]
patch - rebased

Comment 16

5 years ago
Realizing only now it's a Windows XP only failure: https://tbpl.mozilla.org/?tree=Try&rev=82c7ccd6242d

Comment 17

5 years ago
Same problem with Linux here: bug 702776

Updated

5 years ago
Depends on: 703237

Updated

5 years ago
Component: Developer Tools → Developer Tools: Inspector
QA Contact: developer.tools → developer.tools.inspector

Comment 18

5 years ago
Now that bug 703237 is fixed, can we land this patch again?

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Assignee)

Comment 19

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/caf7c101040e
Component: Developer Tools: Inspector → Developer Tools
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
(Assignee)

Comment 20

5 years ago
https://hg.mozilla.org/mozilla-central/rev/caf7c101040e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 11
(Assignee)

Comment 21

5 years ago
Comment on attachment 574564 [details] [diff] [review]
patch - rebased

style only fix. requires test fix in bug 703237 to prevent test failures.
Attachment #574564 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #574564 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 22

5 years ago
patch doesn't apply cleanly due to bug 701212.
Depends on: 701212
(Assignee)

Comment 23

5 years ago
aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/5f68d58cb3fd
status-firefox10: --- → fixed
What is the expected & unexpected hover states for QA to verify this fix?
Whiteboard: [fixed-in-fx-team] → [fixed-in-fx-team][qa?]

Comment 25

5 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #24)
> What is the expected & unexpected hover states for QA to verify this fix?

Expected: on over, the close button of the inspector toolbar should be a bit different (darker iirc, see chrome://browser/skin/devtools/toolbarbutton-close.png)
Unexpected: on over, the close button use a totally wrong and unrelated image
Whiteboard: [fixed-in-fx-team][qa?] → [fixed-in-fx-team][qa+]

Updated

5 years ago
tracking-firefox10: ? → +
I've verified this on Win XP and Win 7.
On hover, the inspector close button is red and on click gets darker.
Setting this to verified fix on Firefox 10b2.

What about the web console close button? On hover it becomes gray instead of red, although on click it turns into the same dark red as the inspector.
status-firefox10: fixed → verified
Keywords: verified-beta
Whiteboard: [fixed-in-fx-team][qa+] → [fixed-in-fx-team][qa+][qa!:10]
(Reporter)

Updated

5 years ago
Whiteboard: [fixed-in-fx-team][qa+][qa!:10] → [qa+][qa!:10]
You need to log in before you can comment on or make changes to this bug.