Last Comment Bug 700348 - fix showBookmarkDialog warnings
: fix showBookmarkDialog warnings
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Marco Bonardo [::mak]
:
Mentors:
Depends on:
Blocks: 629371
  Show dependency treegraph
 
Reported: 2011-11-07 09:55 PST by Marco Bonardo [::mak]
Modified: 2012-02-01 13:58 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (11.72 KB, patch)
2011-11-08 10:53 PST, Marco Bonardo [::mak]
dietrich: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] 2011-11-07 09:55:55 PST
Looks like I forgot to pass into the window handle, that works regardless thanks to a compatibility shim, but complains loudly in the Error Console :(
Comment 1 Marco Bonardo [::mak] 2011-11-08 10:53:21 PST
Created attachment 572896 [details] [diff] [review]
patch v1.0

this adds the missing argument
Comment 2 Dietrich Ayala (:dietrich) 2011-11-11 11:41:32 PST
Comment on attachment 572896 [details] [diff] [review]
patch v1.0

Review of attachment 572896 [details] [diff] [review]:
-----------------------------------------------------------------

r=me w/ question addressed

::: browser/components/sidebar/src/nsSidebar.js
@@ +115,5 @@
>                                                         , "loadInSidebar" ]
>                                           , uri: uri
>                                           , title: aTitle
>                                           , loadBookmarkInSidebar: true
> +                                         }, win);

why changing minimal ui param here?
Comment 3 Marco Bonardo [::mak] 2011-11-11 11:43:19 PST
(In reply to Dietrich Ayala (:dietrich) from comment #2)
> why changing minimal ui param here?

it's a compatibility shim for addons, actually the method figures itself if it's minimalui bu checking if the folderPicker is in hiddenrows. We are not addons :)
Comment 5 Ed Morley [:emorley] 2011-11-12 04:52:42 PST
https://hg.mozilla.org/mozilla-central/rev/9e2b0e520559

Note You need to log in before you can comment on or make changes to this bug.